LDForge

Mise à jour de la page : 15 juin 2013.

Nota : Cette page est obsolète,
Voir :
LDForge Nouvelle version

    Set 700/1 de 1950
J.C. Tchang
 

Ce manuel est basé sur la version 0.1.999b de LDForge. C'est un programme de Santeri Piippo, qui permet de créer des pièces virtuelles au format LDraw.

L'écran principal du programme se divise ainsi :

 

Navigation rapide

 

Téléchargement

Dernière version

Téléchargez le programme sur le forum LDraw.org :

 

Historique

 

Installation

Pré-requis système

Pré-requis logiciel

La bibliothèque LDraw doit être installée :

Les programmes additionnels externes doivent être installés (de préférence). Voir les chapitres Téléchargement respectifs :

Installation de LDForge

Après avoir, si besoin, décompressé le fichier téléchargé, Mettre le dossier obtenu à l'emplacement de votre choix.
Personnellement j'utilise le dossier : C:/LEGO/LDForge.

Configuration de LDForge

Au premier lancement le programme demande le dossier de la bibliothèque LDraw.

Un OK! s'affiche lorsque le bon dossier est sélectionné. On peut ultérieurement changer l'adresse de ce dossier en allant dans le menu : "File / Set LDraw Path".

Il est également bon de configurer les programmes externes. Voir : Paramétrage, onglet "Ext. Programs".

 

Fenêtre graphique

Les éléments de pièce LDraw s'affichent dans la fenêtre graphique, en partie centrale.

Modes d'affichages

Par défaut les faces s'affichent en mode BFC, c'est à dire avec le côté extérieur des faces en vert et le côté intérieur en rouge.

En décochant dans le menu : "File / Settings", onglet "Main settings", case à cocher "Red/green BFC view", on passe en mode couleur des entités (gris la plupart du temps).

En déplaçant dans le menu : "File / Settings", onglet "Main settings", le curseur "Alpha", on modifie la transparence des entités en "Main Color" (16).

Avec le menu "View / Draw Axes" ont ajouter/cacher les axes X rouge, Y vert et Z bleu.
Nota : Pour se rappeler la couleur des axes, voir les icônes de la barre de menu "Move", qui montrent à la fois la couleur et le sens de chaque axe.

Avec le menu "View / Wireframe" ont bascule en mode filaire/surfacique des faces.

Avec le menu "Tools / Toggle Visibility" ont peut cacher/visualiser les pièces sélectionnées.

Voir le chapitre "Mode 2D/3D" pour l'usage et les manipulations d'objets dans la fenêtre graphique.

Copie d'écran

Avec le menu "View / Screencap Part" ont peut générer une image de la fenêtre graphique.

 

Fenêtre listing

Dans la partie droite du programme s'affiche le listing des éléments apparaissant dans le fichier LDraw.

En première colonne un symbole représentant chaque type de donnée.

Pour les données graphiques des triplets (x, y, z) pour chaque point de définition.

Pour les sous-fichiers et primitives le nom du fichier, un triplet de position (x, y, z), et une matrice de 9 valeurs (xX xY xZ yX yY yZ zX zY zZ) pour définir la taille, l'orientation et la déformation.

Si une couleur est affectée aux éléments la ligne dans le listing est affectée de cette couleur. Nota : Si dans le menu : "File / Settings", onglet "Main settings", "Colorize polygons in object list" est coché.

On peut sélectionner une entité en cliquant dessus, en ajouter avec la touche Ctrl et sélectionner une zone avec la touche Maj ou par clic et glisser de la souris.

On peut aussi sélectionner des objets directement dans la fenêtre graphique.

Pour déplacer la sélection dans le listing utiliser les commandes du menu : "Move / Move Up" ou "Move / Move Down", les boutons correspondants, ou les touches "Maj+Flèche haut" et "Maj+Flèche bas".

On peut aussi couper/copier/coller la sélection avec les commandes et boutons habituels.

 

Modes

Mode 2D/3D

Dans le coin en haut à droite il est possible de choisir un mode d'affichage 2D ou 3D (de haut en bas et de gauche à droite):

En vue 2D il est possible de passer entre le mode sélection (Select Mode) et le mode dessin (Draw Mode). On peut déplacer la vue avec le bouton central de la souris, et zoomer avec sa molette.

En vue 3D le mode dessin (Draw Mode) est inactif, seul le mode sélection (Select Mode) est actif. On peut tourner autour des axes X-vue et Y-vue avec le bouton gauche de la souris, déplacer la vue avec le bouton central de la souris, et zoomer avec sa molette.

Avec "View / Reset View" on réinitialise la fenêtre graphique.

Mode sélection

Sélectionner une entité en cliquant dessus avec le bouton gauche de la souris, dans la fenêtre graphique ou dans la liste déroulante à droite.

Sélectionner une entité supplémentaire, utiliser conjointement la touche Ctrl.

Pour sélectionner une plage d'entités sélectionner la première dans la liste, et utiliser conjointement la touche Maj en cliquant sur la dernière.

Utiliser la commande du menu Edit (ou les boutons de la barre d'outils correspondants) :

Mode dessin

Dans la vue de la pièce, en mode 2D, il est possible de dessiner des lignes, triangles et quadrilatères.

Pour créer une ligne cliquer deux fois au même endroit pour le second point. Faire la même chose au troisième ou quatrième point pour un triangle ou un quadrilatère. Un appui sur le bouton droit de la souris annule le point précédent. L'ordre antihoraire des points oriente la face des triangles et quadrilatères vers l'extérieur (en vert).

Attention il est possible de créer des quadrilatères dégénérés (bords croisés ou 3 points alignés).

Par défaut, les objets sont créés dans le plan X, Y ou Z = 0, suivant la vue sélectionnée.

Avec la commande "Edit / Set Draw Depth", il est possible de changer de niveau le plan.

Image de fond

On peut insérer une image de fond avec la commande : "View / Set Overlay Image" :

Nota : Si le format de l'image n'est pas reconnu on obtient un message d'erreur (image .JPG par exemple) :

Puis on peut dessiner sur l'image. Malheureusement, avec la version testée les entités passent derrière l'image (dépend du mode de création de l'image).

La commande : "View / Clear Overlay Image" permet de supprimer l'image de fond.

 

Projet de pièce

Lorsque l'on veut créer une nouvelle pièce, il faut créer un nouveau projet de pièce avec le menu "File / New part".

Renseigner les 2 lignes "Name:" et "Author:", et laisser par défaut les autres cases à cocher. Ces renseignements vont alimenter l'entête du fichier.

Nota : Il faut penser à sauvegarder le fichier avec "File / Save As" en choisissant l'extension DAT.

Sinon reprendre un projet existant avec le menu "File / Open" ou "File / Open Recent / xxxx.dat".

 

Projet de modèle

LDForge est capable de créer des modèles LDraw, mais cela reste assez basique.

Utiliser la commande du menu : "Insert / New Subfile", en sélectionnant les pièces par leur numéro sous l'arborescence "Parts".

Pour l'exemple suivant, le temps de sélection des pièces et leur positionnement peut devenir long.

Nota : Il faut penser à sauvegarder le fichier avec "File / Save As" en choisissant l'extension LDR.

 

Création d'entités

Le système LDraw ne connaît que 5 types d'entités représentés dans le fichier par le premier caractère de chaque ligne commençant par :

Elément LDraw prédéfini (Type 0 à 5)

Avec le menu "Insert / Insert from File", on insère un fichier au format LDraw sélectionné sur le disque dur.

Avec le menu "Insert / Insert Raw", on insère une ou des lignes au format LDraw à partir du presse-papier.

L'insertion se fait après la dernière ligne sélectionnée dans le listing.

Commentaire (Type 0)

Commande accessible par le menu "Insert / New Comment", ou le bouton de la barre d'outils correspondant.

Sous-fichier (Type 1)

Commande accessible par le menu "Insert / New Subfile", ou le bouton de la barre d'outils correspondant.

Insère l'instance d'un sous-fichier (File) à la position donnée, avec une taille et déformation définie par la matrice de transformation (Matrix).

Entrez les valeurs X, Y, Z du point d'insertion dans la boite de dialogue, ou utilisez les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du sous-fichier.

La commande du menu : "Tools / Inline" permet de décomposer un sous-fichier avec ses composants positionnés et configurés dans leur état en cours.

La commande du menu : "Tools / Deep Inline" fait la même chose de façon récursive jusqu'à obtenir des entités de base (ligne, triangle, quadrilatère, ligne conditionnelle).

Ligne (Type 2)

Commande accessible par le menu "Insert / New Line", ou le bouton de la barre d'outils correspondant.

Entrez les valeurs X, Y, Z des points définissant la ligne dans la boite de dialogue, ou utilisez les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut de la ligne.

Voir le chapitre Mode dessin, pour insérer une ligne en mode 2D.

La commande "Tools / Make Borders" crée des lignes sur les bords de triangles ou quadrilatères.

La commande "Tools / Demote conditionals lines" convertit des lignes conditionnelles en lignes simples.

Triangle (Type 3)

Commande accessible par le menu "Insert / New Triangle", ou le bouton de la barre d'outils correspondant.

Entrez les valeurs X, Y, Z des points définissant la facette triangulaire dans la boite de dialogue, ou utilisez les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du triangle.

Voir le chapitre Mode dessin, pour insérer un triangle en mode 2D.

Les quadrilatères peuvent être décomposés en 2 triangles par le commande : "Tools / Split Quads".

Quadrilatère (Type 4)

Commande accessible par le menu "Insert / New Quadrilateral", ou le bouton de la barre d'outils correspondant.

Entrez les valeurs X, Y, Z des points définissant la facette quadrangulaire dans la boite de dialogue, ou utilisez les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du quadrilatère.

Voir le chapitre Mode dessin, pour insérer un quadrilatère en mode 2D.

Les triangles à bord commun et de même couleur peuvent être convertis en quadrilatères avec le programme externe Rectifier.

Ligne conditionnelle (Type 5)

Commande accessible par le menu "Insert / New Conditional Line", ou le bouton de la barre d'outils correspondant.

Sommet ou point (Type 0 !LDFORGE)

Commande accessible par le menu "Insert / New Vertex", ou le bouton de la barre d'outils correspondant.

Entrez les valeurs X, Y, Z du point dans la boite de dialogue, ou utilisez les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du sous-fichier.

La commande "Tools / Make Corner Vertices" crée des points sur les sommets de triangles ou quadrilatères.

Ce type d'entité n'existant pas par défaut dans le format LDraw, il est sauvegardé dans le fichier LDraw sous forme de commentaire spécialisé :
0 !LDFORGE VERTEX 16 20 10 0 pour un sommet en couleur principale (16) positionné à X=20, Y=10, Z=0.

Elément circulaire (Type 0 !LDFORGE)

Commande accessible par le menu "Insert / New Radial", ou le bouton de la barre d'outils correspondant.

Entrez les valeurs X, Y, Z du point d'insertion dans la boite de dialogue, ou utilisez les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du sous-fichier.

Ce type d'entité n'existant pas par défaut dans le format LDraw, il est sauvegardé dans le fichier LDraw sous forme de commentaire spécialisé :
0 !LDFORGE RADIAL CIRCLE 16 1 16 0 0 0 0 1 0 0 0 1 0 0 0 1
0 !LDFORGE RADIAL CYLINDER 16 1 16 0 0 0 0 1 0 0 0 1 0 0 0 1
0 !LDFORGE RADIAL DISC 16 1 16 0 0 0 0 1 0 0 0 1 0 0 0 1
0 !LDFORGE RADIAL DISCNEGATIVE 16 1 16 0 0 0 0 1 0 0 0 1 0 0 0 1
0 !LDFORGE RADIAL RING 16 1 16 0 0 0 0 1 0 0 0 1 0 0 0 1
0 !LDFORGE RADIAL CONE 16 1 16 0 0 0 0 1 0 0 0 1 0 0 0 1
0 !LDFORGE RADIAL CIRCLE 16 1 48 0 0 0 0 1 0 0 0 1 0 0 0 1

Fait double emploi avec les primitives LDraw ???

Nota : Ces éléments peuvent être converties en éléments LDraw avec la commande : "Tools / Radial to Subfiles".

 

Couleur des entités

Toutes les entités graphiques peuvent être affectées d'une couleur. Les couleurs les plus courantes peuvent être sélectionnées à partir des boutons de la barre d'outils, sinon toutes les couleurs disponibles peuvent être sélectionnées par le menu : "Tools / Set Color" ou par le bouton de sélection de couleur dans les boites de dialogue de création d'entités.

La couleur peut être affectée directement au moment de la création d'une entité, ou ultérieurement en faisant une sélection.

Le numéro LDraw des couleurs, leur nom, et leur coloration est défini par le fichier LDConfig.ldr, se trouvant dans le dossier d'installation de la bibliothèque de pièces LDraw.

Il existe 2 couleurs spéciales dans les fichiers de définition des pièces. La couleur 16 pour les faces (triangles et quadrilatères) et sous-fichiers, et la couleur 24 pour les lignes et lignes conditionnelles. Cela permet de définir des couleurs différentes pour le même fichier de pièce dans un fichier modèle.

Normalement un fichier de pièce ne possède pas de couleur affectée, sauf lorsqu'il y a un motif. L'affectation des couleurs peut aider temporairement pour créer les différentes parties d'une pièce, et en particulier pour définir des groupes de données utilisées par les programmes externes.

Les couleurs des faces s'affichent dans la fenêtre graphique si "Red/green BFC view" n'est pas coché dans la boite de dialogue "Settings", onglet "Main Settings". Voir chapitre paramétrage.

On peut affecter une couleur pseudo-aléatoire à une sélection. La commande "Tools / Autocolor", affecte la première couleur non utilisée.

La commande "Tools / Uncolorize", supprime toutes les couleurs (met en couleurs 16 et 24).

 

Sens des faces (BFC)

Le sens des faces permet de définir le côté intérieur et extérieur des faces, pour une meilleure utilisation dans les programmes de rendu.

Les déclarations sur le sens des faces sont accessibles par le menu : "Insert / New BFC Statement".

On peut changer le sens des faces d'une sélection par le menu : "Tools / Invert".

Nota : Le sens des faces s'affichent dans la fenêtre graphique si "Red/green BFC view" est coché dans la boite de dialogue "Settings", onglet "Main Settings". Voir chapitre paramétrage.

 

Modification

Les éléments existants dans le fichier peuvent être modifiés en position et rotation, ou même transformés.

 

Grilles

Les 3 grilles permettent de positionner, déplacer et tourner les objets graphiques suivant un pas plus ou moins fin.

Les valeurs sont définies par le menu : "File / Settings", onglet "Grids".

Le choix de la grille se fait dans le menu : "Move / Coarse Grid", "Move / Medium Grid", "Move / Fine Grid", ou en utilisant les boutons correspondants.

Pour les rotations on peut définir le point de centre avec le menu : "Move / Set Rotation Point".

Par défaut le point de rotation est l'origine de l'objet (Object center) ou un point quelconque (Custom point) qui peut être l'origine du fichier avec les valeurs X=0, Y=0 et Z=0.

Déplacement

Les éléments sélectionnées peuvent être déplacés en X, Y ou Z par les commandes : "Move / Move ...".

Le pas de déplacement dépendant de la grille active et de son paramétrage.

En éditant une entité par le menu : "Edit / Set Contents" ou le menu contextuel "Edit Object", on peut changer ses coordonnées d'insertion ou les coordonnées de ses points de définition.

Avec la commande du menu : "Edit / Replace coordinates", on peut déplacer les entités type 1 ou un sommet d'entité type 2, 3, 4 ou 5.

Rotation

Les éléments sélectionnées peuvent être tournés autour des axes X, Y ou Z par les commandes : "Move / Rotate ...".

Le pas de rotation dépendant de la grille active et de son paramétrage.

Le centre de rotation est défini par défaut autour de l'origine du sous-fichier, ou l'origine de la pièce. On peut définir un point de centre particulier avec la commande : "Move / Set Rotation Point". Voir chapitre "Grilles".

En éditant une entité par le menu : "Edit / Set Contents" ou le menu contextuel "Edit Object", on peut changer ses coordonnées d'insertion ou les coordonnées de ses points de définition.

Symétrie

Pour symétriser une sélection aller dans le menu : "Tools / Flip".

La symétrie se fait par rapport au plan 0 perpendiculaire à l'axe coché dans la boite de dialogue.

Modification du code LDraw

Avec la commande du menu : "Tools / Set Contents" on visualise le code LDraw d'une entité sélectionnée seule. Il est alors possible de la modifier directement.

En jouant sur le code, on peut modifier sa couleur, les valeurs de position des points définissant lignes, triangle et quadrilatère. Pour un sous-fichier on peut changer la position d'insertion ou le transformer complètement. Voir ma page : Déformation de primitives.

Arrondi des données

Avec la commande du menu : "Tools / Round Coordinates" on peut arrondir les données de la sélection à 3 chiffres après la virgule pour les positions et 4 chiffres pour la matrice de transformation.

C'est particulièrement utile après des rotations successives ou la création d'entités par les programmes externes.

Suppression

La sélection courante peut être supprimée par le menu : "Edit / Delete", le menu contextuel "Delete", ou la touche "Suppr (Del)".

Historique des commandes

Avec la commande du menu : "View / Edit History" on visualise la liste des commandes LDForge et d'en supprimer une.

On peut supprimer la dernière commande avec du menu : "Edit / Undo", ou la rejouer avec "Edit / Redo".

 

Programmes externes

Les programmes externes permettent de générer des entités automatiquement. Ils fonctionnent soi sur les éléments sélectionnés lorsqu'ils utilisent une seule liste d'éléments, soi sur une discrimination par couleur lorsque plus d'une liste est nécessaire.

Les données générées sont insérées après la position du curseur dans le listing.

Ces programmes générant des entités avec beaucoup de chiffres après la virgule, il sera sans doute nécessaire d'arrondir les données avec la fonction "Tools / Round Coordinates".

Programme d'extrusion de faces sur une succession de lignes : Ytruder

Voir le manuel du programme : Ytruder, pour plus d'informations sur son utilisation spécifique.

Programme d'optimisation : Rectifier

Voir le manuel du programme : Rectifier, pour plus d'informations sur son utilisation spécifique.

Programme de coupe d'entités : Intersector

Voir le manuel du programme : Intersector, pour plus d'informations sur son utilisation spécifique.

Programme de lignes d'intersections : Isecalc

Génère des lignes à l'intersection de 2 groupes d'entités.

Voir le manuel du programme : Isecalc, pour plus d'informations sur son utilisation spécifique.

Programme d'extrusion de faces réglées : Coverer

Voir le manuel du programme : Coverer, pour plus d'informations sur son utilisation spécifique.

 

Menus

File (Fichier)

View (Visualisation)

Insert (Insertion)

Edit (Edition)

Tools (Outils)

Move (Déplacement)

External Programs (Programmes Externes)

Help (Aide)

 

Menus contextuels

Les commandes principales sont aussi accessibles par le menu contextuel qui s'affiche avec le bouton droit de la souris.

Mode vue 3D Mode vue 2D

 

Barres d'outils

On peut afficher ou cacher les barres d'outils en cliquant avec le bouton droit de la souris dans la zone d'affichage des barres d'outils, puis en cochant ou décochant une des barres.

On peut déplacer les barres d'outils sur les quatre bords de la fenêtre, ou les rendre indépendantes. Pour cela, cliquer sur leur barre de pointillés, à leur gauche ou en haut, puis avec la souris faire glisser la barre à son nouvel emplacement.

Barre d'outils "File" (Fichier)

Barre d'outils "Insert" (Insertion)

Barre d'outils "Edit" (Edition)

Barre d'outils "Select" (Sélection)

Barre d'outils "Move" (Déplacement)

Barre d'outils "Rotate" (Rotation)

Barre d'outils "Grids" (Grilles)

Barre d'outils "View" (Visualisation)

Barre d'outils "Quick Colors" (Couleurs courantes)

Barre d'outils "Tools" (Outils)

Barre d'outils "External Programs" (Programmes externes)

Barre d'outils "Modes" (Modes)

 

Paramétrage

La boite de dialogue du paramétrage de LDForge s'ouvre à partir du menu "File / Settings".
Cliquer sur "OK" pour valider les modifications et sur "Cancel" pour les annuler.

Onglet Main settings, fixe les paramètres généraux :
  • Background color, couleur de fond de la fenêtre graphique.
  • Foreground color, couleur des faces "Main color".
  • Line thickness, épaisseur des lignes (1 par défaut).
  • Alpha, transparence des faces "Main color" (opaque par défaut).
  • Toolbar icon size, taille des boutons des barres d'outils.
  • Colorize polygons in object list, coché colore les polygones dans la liste des objets.
  • Red/green BFC view, coché affiche le sens des faces en rouge (intérieur) et vert (extérieur).
  • Black edges, coché affiche les bords de primitives en noir.
  • Scemantic insertion only, inactif.
Onglet Shortcuts, Change les raccourcis clavier :
  • Set, fixe le raccourci clavier d'une commande LDForge, après appui d'une touche ou combinaison de touches.
  • Reset, remet le raccourci par défaut.
  • Clear, efface le raccourci.
Onglet Quick Colors, Change les boutons de la barre d'outils couleurs :
  • Add, Ajoute un bouton.
  • Remove, Supprime un bouton ou un séparateur.
  • Set, fixe une autre couleur à un bouton.
  • Add Separator, ajoute un séparateur.
  • Move Up, déplace vers le haut.
  • Move Down, déplace vers le bas.
  • Clear, supprime tous les boutons.
Onglet Grids, Change les pas de déplacement et rotation :
  • Coarse, paramètres de la grille large (5 LDU et 45° par défaut).
  • Medium, paramètres de la grille moyenne (1 LDU et 22,5° par défaut).
  • Fine, paramètres de la grille fine (0,1 LDU et 7,5° par défaut).
  • X, pas de déplacement en X.
  • Y, pas de déplacement en Y.
  • Z, pas de déplacement en Z.
  • Angle, pas de rotation en degrés.
Onglet Ext. Programs, Fixe le dossier d'installation des programmes externes :
  • Ytruder, génère des surfaces sur un bord.
  • Rectifier, optimise un fichier de pièce.
  • Intersector, coupe un ensemble de surfaces et de lignes.
  • Isecalc, calcule l'intersection de deux ensembles de surfaces.
  • Coverer, génère des surfaces entre deux chemins.

 

Raccourcis clavier

Table des raccourcis clavier :

Fichier :Touches
Nouveau projetCtrl+N
Ouvrir un projet existantCtrl+O
SauverCtrl+S
Sauver sousCtrl+Maj+S
SortieCtrl+Q
 
Visualisation :Touches
Réinitialisation de la vueCtrl+0
 
Edition :Touches
AnnulerCtrl+Z
Rétablir la dernière action annuléeCtrl+Maj+Z
CouperCtrl+X
CopierCtrl+C
CollerCtrl+V
SupprimerSuppr (Del)
Sélectionner toutCtrl+A
Sélectionner même couleurCtrl+Maj+A
Mode sélectionCtrl+1
Mode dessinCtrl+2
 
Outils :Touches
Fixer la couleurC
Inverser sens des facesCtrl+Maj+W
Décomposer premier niveauCtrl+I
Décomposer tous niveauxCtrl+Maj+I
Insérer une entité par son code LDrawF9
Créer les bordsCtrl+Maj+B
Remplacer les coordonnéesCtrl+R
InverserCtrl+Maj+F
 
Déplacement :Touches
Déplacement liste sélectionnée vers le hautMaj+Touche flèche haut
Déplacement liste sélectionnée vers le basMaj+Touche flèche bas
Déplacement +XTouche flèche droit
Déplacement -XTouche flèche gauche
Déplacement +YTouche flèche page bas
Déplacement -YTouche flèche page haut
Déplacement +ZTouche flèche haut
Déplacement -ZTouche flèche bas
Rotation +XCtrl+Touche flèche droit
Rotation -XCtrl+Touche flèche gauche
Rotation +YCtrl+Touche flèche page bas
Rotation -YCtrl+Touche flèche page haut
Rotation +ZCtrl+Touche flèche haut
Rotation -ZCtrl+Touche flèche bas
 
Aide :Touches
Aide du programmeF1 (inactif)
 

 

Fichiers système

LDForge sauvegarde sa configuration dans le fichier :
C:/Users/[user]/LDForge/ldforge.cfg (remplacer [user] par votre nom d'utilisateur Windows).

LDForge sauvegarde également des fichiers Dump en cas de crash dans le dossier :
C:/Users/[user]/AppData/Local/CrashDumps (remplacer [user] par votre nom d'utilisateur Windows).

 

Améliorations souhaitables

En premier je précise que la version testée (v 0.1.999 Alpha B) est en version alpha. Elle est malgré cela opérationnelle.

Voici une liste d'améliorations souhaitables ou à envisager qui amélioreraient les possibilités du programme et sa facilité d'utilisation.

 

Tutoriels

 

Tutoriel intersection de primitives

Voici un exemple simple d'utilisation de LDForge.

But à atteindre :

Créer les lignes d'intersection de la boite et du cylindre.

1- Mettre ces 2 éléments dans un fichier temporaire et l'ouvrir avec LDForge.
2- Sélectionner les 2 entités.
3- Les décomposer en éléments de base avec la commande : "Tools / Deep Inline".

Coloration :

1- Sélectionner les 3 quadrilatères de la boite et les colorer en jaune (par exemple).
2- Sélectionner les 4 quadrilatères (2+2) du cylindre coupant les faces jaunes et les colorer en vert (par exemple).

Utiliser le programme externe Isecalc :

1- Lancer la commande : "External Program / Isecalc".
2- Sélectionner les 2 couleurs utilisées (ordre indifférent).
3- Valider en cliquant sur le bouton "OK".

Lignes d'intersection :

1- La commande précédente à créé 8 lignes, placées en fin de listing.
2- Sauvegarder le fichier temporaire.
3- Copier les 8 lignes créées dans le fichier temporaire pour les coller dans le fichier final.

Nota : L'usage du fichier temporaire est ici pratique pour garder dans le fichier final les 2 primitives non décomposées, en y ajoutant les 8 lignes d'intersection créées dans le fichier temporaire.

Nota : Si l'usage du fichier temporaire n'est pas nécessaire, on peut enlever globalement les couleurs devenues inutiles avec la commande : "Tools / Uncolorize".

 

Tutoriel création de primitive rect.dat

Voici comment dessiner un parallélogramme et le transformer en primitive LDraw rect.dat.

Dessiner un carré, rectangle ou parallélogramme en mode 2d :

La seule condition à respecter est d'avoir les côtés opposés du quadrilatère parallèles.

1- Passer en mode 2D vue de dessus (par exemple).
2- Passer en mode dessin.
3- Créer le quadrilatère en cliquant 4 fois + 1 validation dans la fenêtre graphique.

Génération des bords :

1- Sélectionner le quadrilatère.
2- Lancer la commande : "Tools / Make Borders".

Génération de la primitive :

1- Sélectionner toutes les entités.
2- Lancer la commande : "External Programs / Rectifier".

 

Droits et Copyright

Le programme LDForge appartient à son auteur : Santeri Piippo.
Les autres programmes cités appartiennent à leurs ayants droits respectifs.

Cette page en Français est de J.C. Tchang.

Traduction et Adaptation : J.C. Tchang.