LDraw Design Pad (LDDP)

Mise à jour de la page : 24 novembre 2009.
    Set 700/1 de 1950
J.C. Tchang
 

LDraw Design Pad, prenant amicalement les diminutifs LDDesignPad ou LDDP est un éditeur de fichier au format LDraw. En conséquence, un environnement LDraw doit être installé, avec la bibliothèque des pièces LDraw.

Il est particulièrement utile aux auteurs de pièces LDraw, et permet d'éditer, modifier, et corriger les pièces en cours de création. Il interface également d'autres programmes externes.

 

Navigation rapide

 

Téléchargement

Téléchargement du programme LDraw Design Pad

Vous pouvez télécharger la dernière version du programme sur le site de Sourceforge : https://sourceforge.net/projects/lddp/.

Nota : pour fonctionner ce programme doit être dans un environnement LDraw installé. Voir le site LDraw.org pour plus de renseignements.

Téléchargement des programmes externes interfacés

Le programme LDraw Design Pad interface quelques programmes qui lui sont complémentaires :

Téléchargement des programmes additionnels (Plugins)

Il est possible de télécharger un certain nombre de programmes additionnels, crées par des tiers. Malheureusement certains de ces programmes ne sont plus mis à jour, et ne fonctionnent plus, ou imparfaitement. D'autres ne sont pas listés car incorporés dans les dernières versions de LDraw Design Pad.

Allez sur la page :
Niels' LDRAW Utils Site pour télécharger les programmes de Niels Karsdorp :

Allez sur la page :
Minifig Generator pour télécharger le programme :

Nota : Semble ne plus fonctionner sur les dernières versions de LDraw Design Pad.

Téléchargez les fichiers :
synceditdll.zip, et synceditsa.zip pour télécharger le programme :

Voir ma page SyncEdit pour plus d'informations.

 

Historique des versions de LDraw Design Pad

LDView existe en versions Windows, Linux, et Mac OS X.
Un module de traduction des menus existe pour certaines anciennes versions 3.x, en Allemand, Italien, Tchèque, mais pas en Français.

 

Usage du programme

Installation

La première chose à faire est d'installer le programme. Personnellement j'utilise le dossier C:\Lego\LDDP, un dossier en parallèle de tous les programmes LDraw que j'utilise.

Lancement

Puis, exécuter le programme. Avec le version 2.0.3 de LDDP, que j'utilise sous Windows Vista, il est préférable de le lancer en glissant/déposant un fichier LDraw existant sur l'icône du programme pour éviter un message d'erreur "Cannot create file "C:\Untitled.lddptmp". Accès refusé.", à cause des droits d'accès contraignants de cette version de Windows.

En raison de quelques "bugs", il est préférable de relancer le programme après l'apparition d'un message d'erreur système (version 2.0.3 de LDDP).

J'utilise encore la version 1.5.7 de LDDP dans certains cas, car elle est plus stable. En particulier, la perte de la position du curseur dans LDDP v2.0.3 lorsque l'on change de fenêtre est plutôt gênante (même si l'on retrouve la ligne concernée dans la ligne de statut en bas de l'écran).

Configuration de base

Ensuite, on peut configurer le programme :

Les autres options de cette boite de dialogue, et de celle qui s'ouvre avec le menu "Tools / Editor options" ne sont à modifier que par les utilisateurs expérimentés, et en cas de besoin.

 

Usage du programme pour la création de pièces

LDDP possède un certain nombre d'outils particulièrement utiles aux créateurs de pièces LDraw.

 

Déplacement et rotation d'entités

Cliquez sur ces icônes pour déplacer d'un pas les entités sélectionnées, en X+, X-, Y+, Y-, Z+, Z-, ou les faire tourner d'un pas angulaire autour des axes X, Y ou Z, également en + ou -.
On peut également utiliser ces mêmes commandes à partir du menu "Movement" (Mouvement).

Le fonctionnement est similaire aux outils qui se trouvent dans MLCad, mais (en version 2.0.3 de LDDP) il n'est pas possible de définir le centre de rotation.

Grilles

Le pas de déplacement ou de rotation est défini suivant 3 grilles : "Coarse" (grosse), "Medium" (moyenne), et "Fine" (fine) sélectionnables par les 3 icônes de droite, ou par le menu "Movement / Grid Granularity", ou également avec les raccourcis clavier qui sont donnés dans ce menu (F7, F8, et F9).

On peut modifier le pas par défaut de ces grilles, en allant dans le menu "Tools / Options", et dans l'onglet "Configuration Values", le sous-onglet "Grid Settings" :

Ajustement à la grille

Avec la commande "Movement / Snap to Grid" (Mouvement / Ajuster à la grille) on peut déplacer les éléments au pas de la grille active la plus proche. Pour les éléments de type 1 c'est la position du sous-fichier qui est arrondi (paramètres 3-4-5), et pour les autres éléments c'est le premier point qui est arrondi, les autres points sont décalés des mêmes valeurs.

 

Symétrisation d'entités

Cliquer sur cette icône pour symétriser les entités sélectionnées par rapport à l'axe X, ou Y, ou Z.

On peut également utiliser cette commande à partir du menu "Movement / Mirror" (Mouvement / Symétrie).

 

Traitement des faces

Cliquer sur cette icône pour inverser le sens des faces des entités sélectionnées de type 3 (triangle) ou 4 (quadrilatère), pour mettre leur face interne à l'extérieur, ou inversement. Ceci est nécessaire pour rendre une pièce conforme au standard BFC (Back Face Culling). Pour plus d'informations sur ce standard voir le chapitre : Méta-commande officielle BFC de ma page Format des fichiers LDraw.

Cliquer sur cette icône pour convertir 2 faces triangulaires coplanaires et adjacentes (type 3) en 1 quadrilatère (type 4).
Nota : Faire attention en faisant cela de ne pas créer des jonctions en "T". Pour plus d'informations sur ce sujet voir le chapitre : Jonction de polygones de ma page Format des fichiers LDraw.

 

Réduction de nombre de décimales

Cliquer sur cette icône pour diminuer le nombre de décimales des coordonnées et paramètres des entités sélectionnées.
Cela est nécessaire car certains programmes peuvent générer des entités avec 6 décimales et plus, ce qui est souvent trop, alors que 3 ou 4 décimales suffisent. Cela augmente inutilement la taille des fichiers. Pour plus d'informations sur ce sujet voir le chapitre : Précision et format des valeurs de ma page Format des fichiers LDraw.

 

Test des erreurs

Cliquer sur cette icône pour afficher toutes les lignes comportant des erreurs de syntaxe, et pouvoir les corriger.

Cette fonction permet également de détecter et supprimer les lignes de commande dupliquées.

Si aucune erreur de syntaxe n'est détecté, un message "No Errors Found!" (Pas d'erreur trouvé!) s'affiche en bas de la fenêtre, sur la gauche de la ligne de statut. Si une ou plusieurs erreurs sont trouvées, alors une sous-fenêtre s'ouvre en bas de la fenêtre principale, les affichant :

En cliquant avec le bouton droit de la souris dans cette sous-fenêtre, on ouvre un menu contextuel :
Marquer toutes les erreurs
Marquer toutes les erreurs du type sélectionné
Démarquer toutes les erreurs
Démarquer toutes les erreurs du type sélectionné

Fixer l'erreur sélectionnée

Fixer toutes les erreurs marquées du type sélectionné
Fixer toutes les erreurs marquées

Fixer toutes les erreurs du type sélectionné
Fixer toutes les erreurs

Copier la liste des erreurs dans le presse-papier

La commande la plus utile est "Fix All Errors" (Fixer toutes les erreurs). Cela permet de corriger la majorité des erreurs d'un seul coup.
Mais la majorité, ne veut pas dire la "totalité" car un certain nombre d'erreurs ne peuvent pas être corrigés automatiquement. C'est souvent le cas ou des triplés de valeurs de la matrice de transformation sont entièrement à "0 0 0". Dans ce cas, il faut changer une des valeurs "0" par "1" ou "-1". La position dans le triplet dépend de l'orientation de l'entité. Commencer par remplacer "0 0 0" par "0 1 0", et regardez si l'orientation n'a pas changé. Si oui, mettez "1 0 0" ou "0 0 1".

Ce test d'erreur est à faire systématiquement en premier avant de reprendre une pièce officielle non à jour (pièce généralement ancienne), ou une pièce non officielle abandonnée.
Ce test est également à faire systématiquement en fin de création d'une nouvelle pièce, ou de modification d'une pièce reprise, pour la valider.

 

Tri des entités

Cliquer sur l'icône pour trier les entités du fichier.

Une fenêtre s'ouvre, permettant d'avoir 3 niveaux de tri, de sélectionner si le tri doit se faire sur tout le fichier ou uniquement la partie sélectionnée, et de trier suivant le sens ascendant ou descendant du fichier :

 

Création et suppression de sous-fichier

Suppression

Cliquer sur l'icône pour décomposer les sous-fichiers sélectionnés (entité de type 1), en lignes de commandes séparées. Cette commande décompose les sous-fichiers sur un seul niveau. C'est-à-dire que si le sous-fichier comporte lui-même des entités de type 1, il faudra (si besoin) relancer la décomposition sur ces entités pour les décomposer également.

Nota : Cette icône reste grisée si aucune ligne de type 1 n'est sélectionnée.

Création

Pour faire l'inverse, et créer un sous-fichier à partir d'entités sélectionnées, il faut passer par le menu "Tools / Subfile Selection". Une fenêtre s'ouvre permettant d'ajouter les informations de l'entête et de donner le nom du fichier :

 

Insertion de méta-commandes, et gestion des commentaires

Il est possible d'insérer des méta-commandes à partir du menu de LDDP.

Entête du fichier

Aller dans "Insert / Standard Part Header" pour insérer les 4 premières lignes de base du fichier LDraw.

Nota : La troisième ligne concernant l'auteur, peut être personnalisé en remplissant les champs de la boite de dialogue ouverte par le menu "Tools / Option" et l'onglet "Configuration Values / User Information".

Aller dans "Insert / History Statement" pour insérer, à la position du curseur, une ligne d'historique des modifications du fichier LDraw.

Méta-commandes du sens des faces (BFC)

Aller dans "Insert / META Statement / BFC Statements / ..." pour insérer, à la position du curseur, une ligne concernant le sens des faces.

Méta-commandes spécifiques

Aller dans "Insert / META Statement / ... / ..." pour insérer, à la position du curseur, une ligne de méta-commande spécifique définissant le comportement du fichier en fonction de divers programmes de modélisation ou de visualisation.

Nota : Normalement ce type de méta-commandes ne doivent pas se trouver dans un fichier de pièce ou de primitive LDraw, mais seulement dans des modèles.

Commentaire

Aller dans "Edit / Comment" pour passer les lignes sélectionnées en commentaire (ajoute "0 " en début de ligne), ou d'utiliser Ctrl+E, ou l'icône correspondante de la barre d'outils "Edit".

Aller dans "Edit / Uncomment" pour décommenter les lignes sélectionnées (supprime "0 " en début de ligne s'il existe), ou d'utiliser Shift+Ctrl+E, ou l'icône correspondante de la barre d'outils "Edit".

Aller dans "Edit / Trim Blank Lines" pour supprimer les lignes vides de la sélection, ou d'utiliser l'icône correspondante de la barre d'outils "Edit".

 

Changement des couleurs

Dans les fichiers au format LDraw, les couleurs sont définis dans les fichiers par un nombre de 0 à 511 positionné en second paramètre de chaque ligne.

 

Couleurs de base

Cliquer sur une des icônes de la barre des couleurs, pour changer la couleur des entités sélectionnées. Les couleurs disponibles dans cette barre vont de la couleur 0 (noir) à 15 (blanc).

Nota : Les 16 icônes des couleurs peuvent être personnalisées en modifiant les champs de la boite de dialogue ouverte par le menu "Tools / Option" et l'onglet "Color Bar". Pour les créateurs de pièce, il peut être bon de remplacer la couleur 7 par la couleur 16 Main Color, mais il n'est pas possible de mettre la couleur 24 Edge Color (Dans la version 2.0.3 de LDDP).

 

Couleurs prédéfinis

Pour les autres couleurs prédéfinis, il faut passer par un remplacement semi-automatique. Pour cela aller dans le menu "Search / Replace Color..." pour ouvrir la boite de dialogue suivante :

Si "Replace Regardless of Original Color" (Remplacer sans se soucier de la couleur originale) n'est pas coché, il faut :
  • Sélectionner dans la liste "Old color:" (Ancienne couleur) la couleur d'origine dans le fichier.
  • Sélectionner dans seconde liste "New color:" (Nouvelle couleur) la nouvelle couleur à appliquer.
  • Si "Replace All" (Remplacer tout) est coché le traitement se fera sur tout le fichier.
  • Si "Replace Current Line Only" (Remplacer uniquement les lignes courantes) est coché le traitement se fera uniquement sur les lignes sélectionnées.
  • Cliquer sur "OK" pour valider.

Si "Replace Regardless of Original Color" (Remplacer sans se soucier de la couleur originale) est coché, le traitement ne tient pas compte de l'ancienne couleur qui peut être quelconque.

 

Couleurs non prédéfinis

Si la couleur n'existe pas dans la liste, il est toujours possible de faire un changement de couleur avec la commande "Search / Replace...", la commande de remplacement d'un texte par un autre.

Ou alors, ..., changer manuellement le second paramètre des lignes.

 

Couleurs aléatoires

Au cours de la création d'une pièce, il est parfois utile de visualiser (via un visualisateur externe, ici LDView) la pièce en mettant des couleurs aléatoires à chaque ligne de commande. Cela aide à voir les limites de chaque entité. Evidemment, il faut ensuite annuler cette commande pour retrouver les couleurs d'origine ("Edit / Undo" ou Ctrl+Z).

La commande se trouve dans le menu "Edit / Randomize Colors in Selection".

Nota : Il est parfois utile de lancer plusieurs fois cette commande, car il peut arriver que 2 éléments contigus soient affectés de la même couleur.

 

Recherche et remplacement de texte

Il est possible de rechercher une chaine de caractères particulière dans le texte du fichier LDraw, avec la commande "Search / Find..." :

Pour passer à l'occurrence suivante, il suffit d'appuyer sur la touche F3.

Il est également possible de remplacer une chaine de caractères particulière par une autre dans le texte du fichier LDraw, avec la commande "Search / Replace..." :

 

Interfaçage avec les programmes complémentaires externes

LDraw Design Pad est interfacé par défaut avec 3 programmes externes complémentaires. Il s'agit de LDView (Visualisateur de fichier LDraw), MLCad (Modeleur de fichier LDraw), et L3Lab (Autre visualisateur de fichier LDraw plus rustique dans la version actuelle). Evidemment, ces programmes doivent avoir été installés et configurés au préalable pour pouvoir être utilisés.

On accède à ces programmes par les 3 premières icônes de la barre d'outil :

Le 4ème bouton permet d'accéder aux divers programmes externes interfacés, s'ils ont été installés.

Le 5ème bouton permet de gérer la fréquence de rafraichissement des données modifiées dans LDDP et envoyées au programmes externes :
Permettre le rafraîchissement si coché.
Envoie du début du fichier à la ligne sélectionnée si coché, sinon envoie tout le fichier.

Rafraîchit l'envoi toutes les 1 seconde.
Rafraîchit l'envoi toutes les 2 secondes.
Rafraîchit l'envoi toutes les 5 secondes.
Utilise l'intervalle personnalisé (0.5 seconde par défaut).
Rafraîchit sur demande.

Nota : L'intervalle personnalisé peut se modifier en changeant la valeur du champ "Custom Poll Interval" de la boite de dialogue ouverte par le menu "Tools / Option" et l'onglet "Configuration Values / Editor Behavior".

Nota : Le rafraîchissement du fichier temporaire nécessite d'écrire automatiquement et très souvent ce fichier, il vaut mieux éviter de faire fonctionner ce programme en créant son fichier temporaire sur une clef USB, ou un disque SSD (à mémoire Flash). Suivant les modèles ce fichier temporaire pourrait détruire la zone d'écriture en quelques heures, ou quelques dizaines d'heures (technologie 2008).

Voici une vue conjointe des 3 programmes principalement utilisés pour la création de pièces LDraw :

 

Interfaçage avec les autres programmes externes

Un certain nombre de programmes externes peuvent être interfacés avec LDDP. Ce nombre n'est pas limitatif, et tout programme fonctionnant sous "Invite de commande" et utilisant préférentiellement un seul fichier d'entrée peut être interfacé. S'il y a plusieurs fichiers d'entrée, il faudra passer par une procédure de commande (.BAT), et figer le nom des fichiers supplémentaires.

Liste des programmes interfacés :

Cette liste n'est pas limitative.

 

Outils Internes

Il est possible d'utiliser quelques outils internes à LDDP, permettant de générer 5 types d'éléments flexibles, et également de transformer une image bitmap en lignes de commandes LDraw.

 

Générateur d'objet souple

Types de fichiers supportés :

Usage :

 

Tuyau flexible : Hose Flexible 8.5L with Tabs

Il s'agit de la pièce 73590B.DAT Hose Flexible 8.5L with Tabs, dont les extrémités utilisent le fichier 750.dat, et ajoute les fichiers 755.dat, 756.dat, et le fichier 754.dat en intermédiaire.

Exemple d'utilisation :

1 14 20 48 0 0 -1 0 -1 0 0 0 0 -1 750.dat
1 14 100 -16 0 1 0 0 0 -1 0 0 0 -1 750.dat
0

Après sélection des 2 premières lignes précédentes dans LDDP et tapé Ctrl+B la boite de dialogue suivante s'ouvre :
  
Résultat visualisé sous LDView, après avoir cliqué sur "Genenerate Curve" dans la boite de dialogue.

 

Tuyau flexible : Hose Flexible 8.5L without Tabs

Il s'agit de la pièce 73590A.DAT Hose Flexible 8.5L without Tabs, dont les extrémités utilisent le fichier 752.dat, et ajoute les fichiers 755.dat, 756.dat, et le fichier 754.dat en intermédiaire.

Exemple d'utilisation :

1 4 20 48 0 0 -1 0 -1 0 0 0 0 -1 752.dat
1 4 100 -16 0 1 0 0 0 -1 0 0 0 -1 752.dat
0

Après sélection des 2 premières lignes précédentes dans LDDP et tapé Ctrl+B la boite de dialogue suivante s'ouvre :
  
Résultat visualisé sous LDView, après avoir cliqué sur "Genenerate Curve" dans la boite de dialogue.

 

Tuyau flexible annelé : Technic Ribbed Hoses

Il s'agit des pièces Technic Ribbed Hoses, comportant de nombreux numéros, et dont voici les longueurs standards en mm : 16, 24, 32, 40, 48, 56, 64, 72, 80, 88, 96, 104, 112, 120, 128, 136, 144, 152, 192, 248.
Les extrémités utilisent le fichier 79.dat, et ajoute le fichier 80.dat en intermédiaire.

Exemple d'utilisation :

1 2 20 48 0 0 -1 0 -1 0 0 0 0 -1 79.dat
1 2 200 -16 0 0 1 0 1 0 0 0 0 -1 79.dat
0

Après sélection des 2 premières lignes précédentes dans LDDP et tapé Ctrl+B la boite de dialogue suivante s'ouvre :
  
Résultat visualisé sous LDView, après avoir entré un nombre d'anneau (il faut un peu tatonner), ici j'ai mis 30, et cliqué sur "Genenerate Curve" dans la boite de dialogue. Nota : Le pas réel des segments est de 6 LDU environ, soit 2,4 à 2,5 mm de pas.

 

Axe Technic flexible : Technic Flexible Axles

Il s'agit de la pièce Technic Flexible Axles, dont les extrémités utilisent le fichier stud3a.dat, et ajoute les fichiers s\faxle1.dat, s\faxle2.dat, s\faxle3.dat, s\faxle4.dat, s\faxle5.dat, et le fichier axlehol8.dat en intermédiaire.

Nota : la hauteur de base de la primitive stud3a.dat est trop courte (4 LDU), et doit être porté à 20 LDU (échelle 5 dans le sens de l'axe).

Exemple d'utilisation :

1 1 20 48 0 0 5 0 1 0 0 0 0 -1 stud3a.dat
1 1 156 -36 0 -1 0 0 0 5 0 0 0 -1 stud3a.dat
0

Après sélection des 2 premières lignes précédentes dans LDDP et tapé Ctrl+B la boite de dialogue suivante s'ouvre :
  
Résultat visualisé sous LDView, après avoir entré une longueur en LDU, ici 200, et cliqué sur "Genenerate Curve" dans la boite de dialogue.

 

Tuyau flexible : Technic Flex-System Hose

Il s'agit de la pièce Technic Flex-System Hose, dont les extrémités utilisent le fichier 76.dat, et ajoute le fichier 77.dat en intermédiaire.

Exemple d'utilisation :

1 2 20 48 0 0 -1 0 -1 0 0 0 0 -1 76.dat
1 2 200 -16 0 0 1 0 1 0 0 0 0 -1 76.dat
0

Après sélection des 2 premières lignes précédentes dans LDDP et tapé Ctrl+B la boite de dialogue suivante s'ouvre :
  
Résultat visualisé sous LDView, après avoir entré une longueur en LDU, ici 200, et cliqué sur "Genenerate Curve" dans la boite de dialogue.

 

Convertisseur d'image BMP en fichier LDraw

Attention cet outil n'est pas le bon moyen pour créer des pièces officielles, car il génère des fichiers volumineux. Il faut plutôt utiliser un outil "vectoriel" pour cela.

Choisir l'image BMP :

Cliquez sur l'image dans la zone de fond, pour choisir la couleur de fond :

La couleur de fond s'affiche :

Choisir alors entre :

Sinon cliquez sur Clear color, pour revenir à None dans le champ Choose a transparent color, et ne pas sélectionner de couleur de fond, et qu'elle reste une couleur normale.

Choisir la taille que prendra 1 pixel de l'image.

Exemple correspondant à la face d'une brique 1x1x1 :
    4 4 -20 0 -10 0 0 -10 0 24 -10 -20 24 -10

Nota : L'image est étendue sur tout le quadrilatère et donc ne garde pas le rapport hauteur/largeur. Créez un quadrilatère ayant les mêmes proportions que l'image pour garder les proportions, ou divisez la largeur en LDU par le nombre de pixels dans ce sens, faire la même chose pour la hauteur, et gardez le plus petit des deux nombre : Soit par exemple : 0,24 LDU / pixels.

 

Programmes additionnels (Plugins)

Ces programmes additionnels sont téléchargés et installés séparément de LDraw Design Pad.

 

Générateur d'Essieux

Installation

Mettre les fichiers PluginWheelGenerator.dll et PluginWheelParts.txt (fichier de données), ainsi que PluginWheelGenerator.bmp (icône) et README PluginWheelGenerator.txt dans le dossier "Plugins" du dossier d'installation de LDDP (par exemple : C:\Lego\LDDP\Plugins).

Utilisation

Accédez au programme dans le menu "Plugins / Wheel Generator".

Holder

Sélectionnez un des types de support (essieu).
Suivant le type peut apparaître jusqu'à 4 zones de saisie pour chaque roue à ajouter. Si le support est déjà équipé de roues, alors les roues sont figées à None.

1st Wheel, 2nd Wheel, ...

Wheel : Sélectionnez la jante de la première roue.
Tyre : Sélectionnez le pneu de la première roue.
Faire de même pour les autres roues.

Nota : le choix de couleurs ne semble pas fonctionner.

Résultat des lignes sous LDDP, après correction des couleurs, et affichage à droite sous LDView :

 

Générateur de Rails

Installation

Mettre les fichiers PluginTrackGenerator.dll et PluginTrackParts.ini (fichier de données), ainsi que PluginTrackGenerator.bmp (icône) et README PluginTrackGenerator.txt dans le dossier "Plugins" du dossier d'installation de LDDP (par exemple : C:\Lego\LDDP\Plugins).

Utilisation

Accédez au programme dans le menu "Plugins / Wheel Generator".

Class of track (Catégorie de rails)

Sélectionnez une des 5 catégories de rails.

Type of track (Type de rails)

Sélectionnez un des types, si disponible pour la catégorie concernée.

Paramétrage de l'insertion

Position : Entrer les coordonnées d'insertion en X Y Z.
Angle : Angle au point de départ en degrés (rotation autour de l'axe Y).
Amount : Nombre de rails identiques à générer.
First Sleeper : Ajouter la première traverse.
Last Sleeper : Ajouter la dernière traverse.
Side Sleeper : Ajouter les traverses latérales (Uniquement pour les croisements).

 

Générateur de Bracelet

Le Plugin "Bracelet Generator" permet de créer des bracelets de bijouterie de la gamme Scala portant des pièces lisses "Tiles".

Installation

Mettre les fichiers PluginBraceletGenerator.dll, et PluginBraceletParts.ini (définitions des pièces), ainsi que PluginColors.txt (définition des couleurs, semblant inutilisé), PluginBraceletGenerator.bmp (icône) et README PluginBraceletGenerator.txt dans le dossier "Plugins" du dossier d'installation de LDDP (par exemple : C:\Lego\LDDP\Plugins).

Mettre la pièce x271.dat dans le dossier des pièces LDraw (par exemple : C:\Lego\LDraw\PARTS), ou remplacer le nom de cette pièce par le nom de la pièce officielle (lorsqu'elle existera) dans le fichier PluginBraceletParts.ini.
Nota : La pièce est officielle depuis la livraison 2010-02 sous le nom 271.

Utilisation

Accédez au programme dans le menu "Plugins / Bracelet Generator".

Bracelet

Angle : Angle entre 2 maillons, ou laisser mettre à jour après avoir rentré en dessous le nombre de pièces, et coché "Full bracelet".
Amount : Nombre de pièces utilisées.
Full Bracelet : Cocher pour avoir un bracelet fermé.

Origin :

First part : Origine au premier maillon.
Center of Bracelet : Ou au centre du bracelet.

Parts Pièces (Ne semble plus fonctionnel)

Part color : Couleur de la pièce maillon.
Tile orientaion : Orientation de la pièce de décor.
Tile color : Couleur de la pièce de décor.
Tile : Description de la pièce de décor (nom).

Tableau des pièces de décoration "Tile" (Ne semble plus fonctionnel)

Part : Numéro d'ordre.
Part color : Couleur de la pièce.
Tile : Description de la pièce (nom).
orientation : Orientation de la pièce.
Tile color : Couleur de la pièce.

Résultat, après avoir cliqué sur "Create", avec les lignes LDraw sous LDDP, et affichage à droite sous LDView :

 

Générateur de Pelle mécanique

Le Plugin "Excavator Generator" permet de créer une combinaison d'un support, un bras et une pelle pour les véhicules de chantier.

Installation

Mettre les fichiers PluginExcavatorGenerator.dll et PluginExcavatorParts.txt (fichier de données), ainsi que PluginColors.txt (définition des couleurs, semblant inutilisé), et PluginExcavatorGenerator.bmp (icône) et README PluginExcavatorGenerator.txt dans le dossier "Plugins" du dossier d'installation de LDDP (par exemple : C:\Lego\LDDP\Plugins).

Utilisation

Accédez au programme dans le menu "Plugins / Excavator Generator".

Holder (support)

Part : Numéro et nom de la pièce.
Color : Couleur.
Origin : Origine en X, Y, et Z.

Arm (Bras)

Part : Numéro et nom de la pièce.
Color : Couleur.
Angle : Angle par rapport au support (+ vers le bas, et - vers le haut).

Bucket (Pelle)

Part : Numéro et nom de la pièce.
Color : Couleur.
Angle : Angle par rapport au support (+ vers le bas, et - vers le haut).

Résultat, après avoir cliqué sur "Create", avec les lignes LDraw sous LDDP, et affichage à droite sous LDView :

 

Générateur de Minifig

Semble ne plus fonctionner, et plus mis-à-jour.
En remplacement utiliser la version incorporé dans MLCad. Voir le chapitre Créer un Minifig (Personnage) dans l'aide en ligne en Français.

 

SyncEdit (version "Plugin")

Editeur de coordonnées de points communs à plusieurs éléments.

Installation

Mettre le fichier SyncEditDll.dll dans le dossier "Plugins" du dossier d'installation de LDDP (par exemple : C:\Lego\LDDP\Plugins).

Utilisation

Accédez au programme dans le menu "Plugins / SyncEdit".

Vous pouvez travailler avec le fichier en entier, ou si une sélection existe dans LDDP, seulement sur cette sélection. Une fenêtre sera affichée avec le premier triplet XYZ d'une ligne de type 2 (ligne) ,3 (triangle), 4 (quadrilatère), et 5 (ligne conditionnelle), surligné en jaune, ainsi que tous les autres triplets XYZ qui ont la même valeur.

Si vous avez un message d'erreur du type "Exception EConvertError...", ou "'0.6667' is not a valid floating point value." au lancement du programme, c'est que vous êtes configuré en clavier français avec "," comme séparateur de décimales. Passer avec le caractère "." temporairement si vous voulez utiliser ce programme, en changeant ce paramètre dans le "Panneau de configuration / Options régionales" et dans l'onglet "Formats", cliquer sur "Personnaliser ce format...". Dans l'onglet "Nombres" de la fenêtre qui s'ouvre, mettre "." dans le champ "Symbole décimal:", au lieu de "," et valider en cliquant sur "Valider".
A la fin de l'utilisation de SyncEdit, il suffit de remettre "," à la place de "." et valider.

Se déplacer de coordonnées en coordonnées en cliquant dans la fenêtre de gauche, et/ou sur les boutons "Prévious" (Précédent), ou "Next" (suivant).

Modifier les coordonnées dans les champs :

Valider la modification pour la ligne en cours grisée, en cliquant sur "Set current only" (Figer le courant uniquement), ou sur "Set all" (Figer tout), pour modifier toutes les coordonnées ayant la même valeur.

Valider l'ensemble des modifications en cliquant sur "OK", ou les annuler en cliquant sur "Cancel" (annule), et ainsi retourner dans LDDP.

 

SyncEdit (version autonome)

Il existe une version autonome de SyncEdit. Voir à ce sujet la page SyncEdit pour plus d'informations.

Nota : Cette version peut également être utilisée comme programme externe à LDDP.

 

Droits et copyright

Le programme LDraw Design Pad est de (C) Orion Pobursky.

Vous pouvez le retrouver sur sa page : Home Page

Les programmes additionnels appartiennent à leur auteurs respectifs :

Traduction et Adaptation : J.C. Tchang.