LDView

Mise à jour de la page : 9 mars 2014.
    Set 700/1 de 1950
J.C. Tchang
 

LDView est un visualiseur de fichier au format LDraw. Il nécessite donc qu'un environnement LDraw soit installé.

 

Navigation rapide

 

Téléchargement

 

Historique des versions

LDView existe en versions Windows, Linux, et Mac OS X.
Un module de traduction des menus existe pour certaines anciennes versions 3.x, en Allemand, Italien, Tchèque, mais pas en Français.

 

Usage du programme

Voici un descriptif succinct de quelques fonctionnalités du programme pour les créateurs de pièces LDraw, et une utilisation générale. Je n'ai pas fait de manuel complet de tous les modes d'affichage.

Manipulation de la vue

Mode Vue (View Mode)

Rotation du modèle dans la vue : Cliquer avec le bouton gauche de la souris dans la vue, et déplacer la souris pour faire tourner le modèle autour des axes X et Y vue. On peut aussi utiliser les flèches du clavier et accélérer le mouvement en combinaison avec la touche "Maj".

Déplacement : Cliquer avec le bouton central de la souris dans la vue, et déplacer la souris pour déplacer le modèle dans le plan de la vue.

Zoom : Cliquer avec le bouton droit de la souris dans la vue, et déplacer la souris verticalement pour agrandir ou diminuer le modèle. On peut aussi utiliser la molette de la souris.

Mode Vol-à-travers (Fly-through Mode)

Rotation autour du point de vue : Cliquer avec le bouton gauche de la souris dans la vue, et déplacer la souris pour faire tourner le modèle autour du point de vue. On peut aussi utiliser les flèches du clavier et accélérer le mouvement en combinaison avec la touche "Maj".

Zoom : Cliquer avec le bouton droit de la souris dans la vue, et déplacer la souris verticalement pour agrandir ou diminuer le modèle jusqu'à passer au travers si le modèle est au milieu de l'écran. On peut aussi utiliser la molette de la souris.

Sélection de vue standard

Avec le menu : "View / Viewing Angles", il est possible de sélection une des 6 vues standards plus une septième la vue Iso 3D.

Nota : Ces vues restent malgré tout avec un point de fuite et sont donc non planes. On peut jouer avec ce point de fuite, avec "Edit / Preferences", onglet "General", champ "Field of view". Mettre à "0.1" pour avoir des vues "presque" planes.

Sélection d'un sous-modèle

Il est possible de sélectionner un sous-modèle dans un modèle multiple (fichier .mpd) avec la commande du menu "Tools/MPD Model selection..." (Ctrl+M). La boite de dialogue suivante s'affiche :


Il suffit de sélectionner un des modèles pour qu'il s'affiche dans la fenêtre principale.

Sélection d'une étape de construction (modèle ou pièce)

A partir de la barre d'outils montré ci-dessus, il est possible d'afficher une partie seulement du modèle. Chaque étape de construction est défini dans le fichier par une ligne d'étape :
0 STEP

Pour les pièces qui ne comportent normalement pas de ligne d'étapes, il est préférable de passer par le programme LDDesign Pad qui permet d'afficher dans LDView la pièce du début du fichier à la position du curseur.

Arbre de construction

Il est possible d'afficher l'arbre de construction du modèle ou de la pièce en cours d'affichage avec la commande du menu "Tools/Model tree..." (Ctrl+T). La boite de dialogue suivante s'affiche :

On peut descendre dans l'arbre de modèle en sous-modèle, puis pièce, sous-pièce ou primitive. La boite de dialogue affiche le contenu des fichiers.

Le bouton [Options] permet de sélectionner les catégories de lignes du fichier à afficher ou non.

En cochant le champ "Highlight selected line", il est possible de mettre dans la fenêtre principale la géométrie de la ligne sélectionnée en surbrillance. La case à coté permet de changer la couleur de la surbrillance :

Exportation

Il est possible d'exporter la pièce en cours d'affichage avec la commande du menu "File/Export..." (Ctrl+E) aux formats :

Il est aussi possible d'exporter des images avec la commande du menu "File/Save Snapshot..." (Ctrl+S) aux formats :

Cliquez sur le bouton [Options...] pour paramétrer le format de sortie (.JPG uniquement), et cocher les différents champs pour définir la taille de l'image, 1 image ou 1 par étape, etc...

Il est bien sur possible d'imprimer avec la commande du menu "File/Print..." (Ctrl+P), et de paramétrer l'impression avec "File/Page Setup...".

Exportation vers Pov-Ray (POV)

Pour exporter le modèle en cours au format POV-Ray, utilisez le menu : "File/ Export", puis sélectionnez : "POV: POV-Ray Scene File" dans le champ "Type". Cliquez sur le bouton "Options..." pour changer les options de création du fichier.

General : Général :

  • Quality : Qualité :
    • Bounding boxes only : Seulement les boites englobantes.
    • No refraction : Sans réfraction.
    • Normal : Normale.
    • Include stud logos : Avec les logos "LEGO" sur les tenons.

Aspec Ratio : Proportions Largeur:Hauteur de l'image :

  • Automatic : Rapport automatique.
  • 5:4, 4:3, 3:2, 5:3, 16/9, 2.35/1 : Rapport correspondant.
  • Current LDView aspect ratio : Rapport de la fenêtre LDView en cours.
  • Custom : Personnalisé.

Custom aspect ratio (must be select "Custom" above) : Rapport personnalisé à rentrer dans le champ à droite : 1.5 pour rapport 3:2 ("Custom" doit être sélectionné dans le menu précédent).

Include Floor : Ajoute le sol :

  • Floor Axis : Sol perpendiculaire à l'axe X / Y (défaut) / Z.
  • X : Sol à droite du modèle.
  • Y : Sol au-dessous du modèle.
  • Z : Sol derrière le modèle.

Reflections : Ajoute les réflexions.

Shadows : Ajoute les ombres.

Fix mirrored stud logos : Corrige les logos de tenons symétrisés.

Top include filename (empty for not top include) : Fichier "#include" à insérer après l'entête du fichier de sortie. Le champ doit être vide si aucun fichier n'est à inclure. Nota : POV-Ray doit pouvoir trouver ce fichier.

Bottom include filename (empty for not top include) : Fichier "#include" à insérer à la fin du fichier de sortie. Le champ doit être vide si aucun fichier n'est à inclure. Nota : POV-Ray doit pouvoir trouver ce fichier.


Geometry : Géométrie :

  • Primitive Substitution : Substitution de primitive :
    • Seam Width : Largeur du joint.
  • Edges Lines : Lignes de bord :
    • Conditional Edge Lines : Lignes conditionnelles.
    • Edge line radius : Rayon des lignes.
  • Smooth curves : Lissage des courbes.
  • Hide studs : Cache les tenons.

Native POV Geometry : Géométrie au format natif POV :

  • Use inline POV statements in LDraw parts : Utilise les déclarations POV contenues dans les pièces LDraw.
  • Search for POV replacements for LDraw parts : Recherche des substitutions POV contenues pour les pièces LDraw.
  • Use XML mapping file : Utilise un fichier de correspondance au format XML.
    • Path to XML mapping file : Chemin d'accès au fichier. Si le champ est vide avec l'option "Use XML mapping file" cochée, LDView utilisera LGEO.xml devant se trouver dans le dossier d'installation de LDView.
    • Browse : Recherche du fichier.

Lighting : Eclairage :

  • Ambient : Lumière ambiante.
  • Diffuse : Lumière diffuse.

Material Properties : Propriétés des matériaux :

  • Reflection : Réflexion.
  • Phong Amount : Equivalent Phong.
  • Phong Size : Taille Phong.

Transparent Material Properties : Propriétés des matériaux transparents :

  • Reflection : Réflexion.
  • Filter : Filtre.
  • Index of Refraction : Index de réfraction.

Rubber Material Properties : Propriétés des matériaux caoutchouc :

  • Reflection : Réflexion.
  • Phong Amount : Equivalent Phong.
  • Phong Size : Taille Phong.

Chrome Material Properties : Propriétés des matériaux chromés :

  • Reflection : Réflexion.
  • Brillance : Brillance.
  • Specular : Spécularité.
  • Roughness : Rugosité.

Exportation au format Stéréolithographique (STL)

Pour exporter le modèle en cours au format STL, utilisez le menu : "File/ Export", puis sélectionnez : "STL: Stereo Lithography File" dans le champ "Type". Cliquez sur le bouton "Options..." pour changer les options de création du fichier.

Scale : Echelle :

  • LDraw Units : Unité LDraw (LDU).
  • inches : Pouce.
  • cm : Centimètre.
  • mm : Millimètre.

Exportation au format 3D-Studio (3DS)

Pour exporter le modèle en cours au format 3DS, utilisez le menu : "File/ Export", puis sélectionnez : "3DS: 3D-Studio File" dans le champ "Type". Cliquez sur le bouton "Options..." pour changer les options de création du fichier.

Seams : Joints (espace simulé entre 2 briques emboitées) :

  • Seam Width : Largeur du joint.

Liste des pièces

Il est possible de créer un fichier au format HTML de la liste des pièces contenues dans un modèle LDraw (.ldr ou .mpd). La commande se trouve dans le menu : "Tools / Parts List..." :

Le résultat dépend des options choisies, avec l'image du modèle, et une liste paramétrée en cochant les colonnes désirées, et leur ordre d'affichage :

Nota : l'affichage d'une vue de chaque pièce, nécessite un accès Internet. Ces images sont récupérées du site peeron.com.
L'image du modèle est générée à partir de la position par défaut. Pour définir sa propre vue par défaut, il faut orienter le vue comme désirée, puis la sauvegarder (menu : View / Viewing Angles / Save Current as Default), et la figer (menu : View / Reset View).

Il existe un utilitaire qui permet de gérer ultérieurement le fichier généré. Voir : LDView Parts List Sorter.

 

Vérification BFC des pièces

L'utilisation de LDView est une aide à la création de pièces LDraw. Il permet en particulier de vérifier le sens des faces (BFC ou Back Face Culing), et d'afficher en vert leur face externe, et en rouge leur face interne. Si la face est mal construite (côtés qui se croisent) ou déclarée non BFC (NOCERTIFY) elle s'affiche alors en bleu.

Le moyen de n'afficher qu'une partie des éléments composant la pièce est de passer par LDraw Design Pad, configuré avec "Poll To Selected Line" (Aller jusqu'à la ligne sélectionnée), et de lancer LDView à partir de ce programme en cliquant sur l'icone "Start LDView".

Nota : Dans le menu : "Edit / Preferences", dans la boite de dialogue qui s'ouvre, onglet "Effects", la case à cocher "Lighting" doit être cochée pour afficher le sens BFC des faces, sinon c'est leur couleur par défaut qui s'affiche".

 

Liste des erreurs et attentions


Ce programme permet également d'afficher la liste des pièces et primitives renommées dans un modèle, dans sa fenêtre "LDView Errors & Warnings", accessible dans le menu "Tools / LDView Errors & Warnings", en cochant "Include Warnings" au bas de la fenêtre.

 

Menus

File (Fichier)

Edit (Edition)

View (Visualisation)

Step (Etape)

Tools (Outils)

Help (Aide)

 

Barres d'outils

On peut afficher ou cacher les barres d'outils en cliquant avec le bouton droit de la souris dans la zone d'affichage des barres d'outils, puis en cochant ou décochant une des barres.

Barre d'outils "Main" (Principale) par défaut

Barre d'outils "Steps" (Etapes de construction)

Outils supplémentaires

Il est possible de modifier le contenu de la barre d'outils principale en cliquant avec le bouton droit de la souris dans cette barre et en sélectionnant "Customise...". Une boite de dialogue s'ouvre :

Il suffit d'ajouter, ou supprimer des boutons dans la barre d'outils avec les boutons "Ajouter" ou "Supprimer". On peut également ajouter des séparateurs entre groupes de boutons, et le bouton "Réinitialiser" permet de retrouver la barre d'origine.

L'ordre peut être changé avec les boutons "Monter" et "Descendre". On peut également ajouter des séparateurs entre groupes de boutons, et le bouton "Réinitialiser" permet de retrouver la barre d'origine.

Pour la création de pièces un bouton est particulièrement utile : Le bouton "BFC".

Outils supplémentaires disponibles :

 

Paramétrage

La boite de dialogue du paramétrage de LDView s'ouvre à partir du menu "Edit / Preferences", ou du bouton "Preferences" de la barre d'outils principale.
Cliquer sur "OK" pour valider les modifications, sur "Annuler" pour les annuler, ou sur "Appliquer" pour appliquer les modifications sans sortir de la boite de dialogue.

Cliquer sur "Reset" pour réinitialiser les paramètres de chaque onglet.

Onglet General, fixe les paramètres généraux :
  • Antialiasing, Anti-crénelage :
    • FSAA, Anti-crénelage.
    • Antialiased lines, Anti-crénelage des lignes de bords.
  • Colors, Couleurs :
    • Background, sélection de la couleur de fond de la fenêtre graphique.
    • Default, sélection de la couleur des faces "Main color" (16).
    • Transparent, Transparent.
    • Process ldconfig.ldr, utilise la définition des couleurs du fichier ldconfig.ldr, se trouvant dans le dossier de la bibliothèque des pièces LDraw.
    • Random colors, coché affiche les pièces d'un modèle ou les faces d'une pièce avec des couleurs aléatoires.
  • Misc, Divers :
    • Show frame rate, coché affiche.
    • Show Axes, coché affiche les axes (X=bleu, Y=vert, Z=rouge).
    • Show errors after loading, coché affiche.
    • Fullscreen refresh override, coché affiche.
    • Field of View, coché affiche.
    • Memory Usage, Usage de la mémoire vive (Low=Basse, Medium=Moyenne, High=Haute).
  • Default Save Directories, Dossiers de sauvegarde par défaut :
    • Snapshots, image de la fenêtre graphique.
      • Model, dossier du fichier ouvert.
      • Last Saved Snapshot, dossier de sauvegarde de la dernière image.
      • Specified, dossier spécifié dans le champ à droite.
    • Parts List, liste des pièces.
      • Model, dossier du fichier ouvert.
      • Last Saved Part List, dossier de sauvegarde de la dernière liste.
      • Specified, dossier spécifié dans le champ à droite.
    • Export, exportation.
      • Model, dossier du fichier ouvert.
      • Last Saved Export, dossier de sauvegarde de la dernière exportation.
      • Specified, dossier spécifié dans le champ à droite.

Onglet Geometry, Change la visualisation :
  • Model, Pièces du modèle :
    • Seem Width, coché, affiche un espace entre chaque pièce, de 0 à 5 LDU.
    • Part bounding boxes only, coché affiche les boites englobantes de chaque pièce.
  • Wireframe, coché passe en mode filaire sinon mode surfacique :
    • Fog, coché, affiche flou les bords les plus lointains.
    • Remove hidden lines, coché supprime les lignes cachées.
    • Thickness, épaisseur des lignes (de 1 à 5).
  • BFC, coché affiche le sens des faces :
    • Red back faces, Rouge = Arrière des faces.
    • Green front faces, Vert = Avant des faces.
    • Blue neutral faces, Bleu = Faces non certifiées BFC ou non valides.
  • Edge Lines, coché affiche les lignes :
    • Show edges only, coché affiche les lignes de bords.
    • Conditional lines, coché affiche les lignes conditionnelles.
      • Show all, coché affiche toutes les lignes conditionnelles.
      • Show control points, coché affiche les points de contrôle des lignes conditionnelles.
    • High quality, coché affiche en haute qualité.
    • Always black, coché affiche les lignes conditionnelles en noir.
    • Thickness, épaisseur des lignes conditionnelles (de 1 à 5).

Onglet Effects, Change les effets de visualisation :
  • Lighting, lumière :
    • High quality, coché, affiche avec une meilleure qualité.
    • Subdued, coché affiche un effet tamisé.
    • Specular highlight, coché affiche un effet surbrillance spéculaire.
    • Alternate setup, coché utilise un paramétrage alternatif.
    • Light direction, sélectionner une des neuf directions de la lumière.
    • Use LIGHT.DAT lights, utilise les lumières définies par des entités LIGHT.DAT.
      • Replace standard light, coché remplace la lumière standard.
    • Hide LIGHT.DAT geometry, coché cache la géométrie des entités LDraw LIGHT.DAT.
  • Stereo, coché affiche deux fois le modèle pour vue stéréo :
    • Cross-eyed, en louchant.
    • Parallel, parallèle.
    • Amount, force de l'effet stéréo.
  • Wireframe cutaway, coché :
    • Color, .
    • Monochrome, .
    • Opacity, .
    • Thickness, épaisseur .
  • Transparency, transparence :
    • Sort, .
    • Stipple, .
  • Misc, divers :
    • Flat shading, .
    • Smooth curves, .

Onglet Primitives, Change les paramètres des primitives :
  • Primitive substitution, substitution des primitives circulaires :
    • Curve quality, pousser le curseur vers la droite pour augmenter la qualité des courbes.
  • Textures, images servant de texture :
    • Use texture maps, coché utilise la texture de facettes.
    • Texture studs, coché utilise la texture de tenons.
      • Nearest filtering, .
      • Bilinear filtering, .
      • Trilinear filtering, .
      • Anisotropic filtering, .
  • Misc, divers :
    • Low quality studs (faster), tenons de basse qualité (rapide).
    • Use hi-res primitives when available, utilise les primitives de haute résolution lorsque c'est possible.

Onglet Updates, mise à jour de la bibliothèque de pièces :
  • Internet Proxy, Internet :
    • Direct connection to the Internet, Connexion directe à Internet.
    • Use simple Windows proxy configuration, utilise la configuration de connexion Windows.
    • Manual proxy configuration, utilise la configuration manuelle.
      • Proxy, adresse.
      • Port, numéro du port.
  • Missing Parts, pièces manquantes :
    • Automatically check LDraw.org for missing parts, Vérifie automatiquement sur le site LDraw.org la présence de pièce manquante.
      • Days between missing part checks, Nombre de jours entre deux vérifications de pièce manquante.
      • Days between updated part checks, Nombre de jours entre deux vérifications de pièce mise à jour.
  • Nota : Les changements de paramètres dans cet onglet prend effet seulement au prochain chargement d'un modèle ou si une mise-à-jour de la bibliothèque est effectuée.

Onglet Preference Sets, Ensemble de paramétrages :
  • Use the following preference set, utiliser l'un des ensembles de paramétrage suivant.
  • Hot Key..., raccourcis clavier.
  • Delete, supprime l'ensemble sélectionné.
  • New, crée un nouvel ensemble avec les paramètres en cours.

 

Raccourcis clavier

Table des raccourcis clavier :

Fichier :Touches
Ouvrir un fichier existantCtrl+O
Sauver une image écranCtrl+S
ExporterCtrl+E
Recharger le fichierF5
Annuler le chargement du fichierEchap (Esc)
ImpressionCtrl+P
SortieCtrl+Q
 
Edition :Touches
Configuration de LDViewCtrl+Maj+P
 
Visualisation :Touches
Mode Plein écran/FenêtreCtrl+Entrée
Afficher/Cacher la barre d'outilsCtrl+Maj+T
Afficher/Cacher la barre de statutCtrl+Maj+S
Réinitialiser la vueCtrl+R
Zoom au mieuxCtrl+F
Aligner sur la verticaleCtrl+U
Mode examen du modèleCtrl+Maj+X
Mode à travers du modèleCtrl+Maj+F
Vue de faceCtrl+1
Vue arrièreCtrl+2
Vue de gaucheCtrl+3
Vue de droiteCtrl+4
Vue de dessusCtrl+5
Vue de dessousCtrl+6
Vue Latitude/Longitude donnéeCtrl+9
Vue 3D IsométriqueCtrl+0
RotationTouches fléchées
Rotation rapideMaj+Touches fléchées
 
Etapes de construction :Touches
Première étapeOrigine
Etape précédentePg préc.
Etape suivantePg suiv.
Dernière étapeFin
Aller à l'étape...Ctrl+G
 
Outils :Touches
Fenêtre des erreursCtrl+Maj+E
Liste des piècesCtrl+L
Arborescence des commandes LDraw du fichierCtrl+T
Boite englobante du modèleCtrl+B
Sélection du modèle d'un fichier MPDCtrl+M
 
Aide :Touches
Aide du programmeF1 (en Anglais)
 

 

Droits et copyright

Le programme LDView est de (C) Travis Cobbs.
Voir sa page principale : LDView home

Traduction et Adaptation : J.C. Tchang.