LDForge

Mise à jour de la page : 10 novembre 2014.
    Set 700/1 de 1950
J.C. Tchang
 

Ce manuel est basé sur la version 0.3 de LDForge. C'est un programme de Santeri Piippo, qui permet de créer ou modifier des pièces virtuelles au format LDraw.

L'écran principal du programme se divise ainsi :

Attention, la version actuelle testée (v0.3) est fonctionnelle, mais a tendance à planter le programme avec perte de données sur une sélection de ligne dans la fenêtre graphique ou un "inline", alors sauvegardez souvent.

 

Navigation rapide

 

Téléchargement

Dernière version

Télécharger le programme sur la page de l'auteur :

 

Historique

 

Installation

Pré-requis système

Pré-requis logiciel

La bibliothèque LDraw doit être installée :

Les programmes additionnels externes doivent être installés (de préférence). Voir les chapitres Téléchargement respectifs :

Installation de LDForge

Décompresser le fichier téléchargé avec 7-Zip par exemple, puis mettre le dossier obtenu à l'emplacement de votre choix.
Personnellement, j'utilise le dossier : C:/LEGO/LDForge.

Configuration de LDForge

Au premier lancement le programme demande le dossier de la bibliothèque LDraw.

Un OK! s'affiche lorsque le bon dossier est sélectionné. On peut ultérieurement changer l'adresse de ce dossier en allant dans le menu : "File / Set LDraw Path".

Au premier lancement le programme demande ensuite votre profil de créateur de pièce. Voir au chapitre Paramétrage l'onglet : Profile.

Il est également bon de configurer les programmes externes. Voir au chapitre Paramétrage l'onglet : External Programs.

A chaque mise à jour de la bibliothèque LDraw il faut mettre à jour la liste des primitives avec la commande "File / Scan Primitives".

 

Projet de pièce

Un projet de pièce est le but principal de LDForge, c'est-à-dire éditer un fichier au format LDraw pour créer une pièce Lego. Si la pièce comporte des éléments répétitifs, ils peuvent être mis dans un ou plusieurs sous-fichiers appelés dans le fichier principal. Les éléments très utilisés sont définis dans des fichiers de primitives.

Nouveau projet

Lorsque l'on veut créer une nouvelle pièce, il faut créer un nouveau projet de pièce avec le menu "File / New Part".

Renseigner les 2 lignes "Title" et "Author", et laisser par défaut les autres cases à cocher. Ces renseignements vont alimenter l'entête du fichier.

On peut créer un nouveau projet sans entête avec le menu "File / New File". C'est pratique par exemple pour travailler sur quelques entités dans un fichier temporaire.

Nota : Il faut penser à sauvegarder le fichier avec "File / Save As" en choisissant l'extension DAT. Si le fichier n'est pas sauvegardé le symbole d'une disquette apparait à gauche de l'onglet.

Reprendre un projet

Sinon reprendre un projet existant avec le menu "File / Open" ou "File / Open Recent... / xxxx.dat".

On peut également charger un fichier de pièce non officielle directement sur LDraw.org avec le menu "File / Download From..." en prenant "Parts tracker" comme source.

Ou n'importe quel fichier LDraw sur Internet avec "File / Download From..." en prenant "Custom URL" comme source et en donnant l'adresse du fichier.

Entête du fichier

Il s'agit des premières lignes écrites dans le fichier.

Lorsque l'on crée une nouvelle pièce avec le menu "File / New Part".

Renseigner les 2 lignes "Title" et "Author", et laisser en principe par défaut les cases à cocher. Ces renseignements vont alimenter l'entête du fichier.

Lorsque l'on modifie un fichier déjà soumis sur LDraw.org, il faut ajouter une ligne de commentaire d'historique de la modification avec le menu "Tools / Add History Line".

Exemple d'entête affiché dans le listing de LDForge :

Création de sous-fichier

On peut mettre une sélection dans un sous-fichier avec la commande "Subfile Selection" du menu contextuel.

Cette commande crée un nouveau fichier sauvegardé dans un sous-dossier "s" et ce fichier est édité dans un nouvel onglet. La sélection est remplacée par une référence au sous fichier dans le listing de la pièce principale.

Décomposition de sous-fichier

Avec la commande "Tools / Inline" il est possible de décomposer un sous-fichier pour mettre ses entités dans le fichier principal. Plante le programme sur la version testée.

Avec la commande "Tools / Deep Inline" on décompose le sous-fichier de façon récursive jusqu'à le remplacer par les entités de base (type 2 à 5). Cela décompose en même temps les primitives.

 

Projet de modèle

LDForge est capable de créer et afficher des modèles LDraw, mais cela n'est pas son but initial et reste assez basique.

Utiliser la commande du menu : "Insert / New Subfile Reference", en tapant un numéro de pièce dans le champ "File", puis déplacer la pièce à son emplacement.

Pour l'exemple suivant, le temps de sélection des pièces et leur positionnement peut devenir long.

Nota : Il faut penser à sauvegarder le fichier avec "File / Save As" en choisissant l'extension LDR.

 

Projet de primitive circulaire

LDForge est capable de générer le fichier DAT d'une primitive circulaire lorsque qu'elle manque à la bibliothèque LDraw.

Le générateur est ouvert par la commande "Tools / Generate Primitive" :

Lorsque l'on clique sur le bouton "OK" le fichier est généré et peut être sauvegardé.

Nota : Le Mode cercle peut générer des primitives de disques ou d'anneaux s'ils n'existent pas dans la bibliothèque.

 

Fenêtre graphique

Les éléments de pièce LDraw s'affichent dans la fenêtre graphique.

Modes d'affichages

Par défaut les faces s'affichent avec leur couleur déclarée ("Main Color" ou gris la plupart du temps).

En cochant dans le menu "View / Draw surfaces", "View / Draw edgelines" ou "View / Draw conditional lines" ont peut montrer/cacher les entités de type face, ligne de bord ou ligne conditionnelle.

En cochant dans le menu : "View / BFC Red/green View", on passe en mode BFC montrant le sens des faces.

En déplaçant dans le menu : "File / Settings", onglet "General", le curseur "Main color alpha", on modifie la transparence des entités en "Main Color" (16).

Avec le menu "View / Draw Axes" ont peut montrer/cacher les axes X rouge, Y vert et Z bleu.

Avec le menu "View / Wireframe" ont bascule en mode filaire/surfacique des faces.

Avec le menu "Tools / Toggle Visibility" ont peut cacher/visualiser les pièces sélectionnées.

Voir le chapitre "Mode 2D/3D" pour l'usage et les manipulations d'objets dans la fenêtre graphique.

Copie d'écran

Avec le menu "View / Screenshot" ont peut générer une image de la fenêtre graphique, au format PNG, JPG (???) ou BMP.

 

Fenêtre listing

Dans la partie droite du programme, sous le bouton "Document", s'affiche le listing des éléments apparaissant dans le fichier LDraw.

En première colonne un symbole représente chaque type de donnée.

Pour les données graphiques il y a un triplet (x, y, z) pour chaque point de définition.

Pour les sous-fichiers et primitives le nom du fichier, un triplet de position (x, y, z), et une matrice de 9 valeurs (xX xY xZ yX yY yZ zX zY zZ) pour définir la taille, l'orientation et la déformation.

Si une couleur est affectée aux éléments, la ligne dans le listing est affectée de cette couleur. Nota : Si dans le menu : "File / Settings", onglet "Interface", "Colorize objects in list view" est coché.

Si une entité est cachée dans la fenêtre graphique, cette entité passe en italique dans le listing.

On peut sélectionner une entité en cliquant dessus, en ajouter avec la touche Ctrl et sélectionner une zone avec la touche Maj ou par clic et glisser de la souris.

On peut aussi sélectionner des objets directement dans la fenêtre graphique.

Pour déplacer la sélection dans le listing utiliser les commandes du menu : "Move / Object List / Move Up" ou "Move / Object List / Move Down", ou utiliser les touches "Maj+Flèche page haut" et "Maj+Flèche page bas".

On peut aussi couper/copier/coller la sélection avec les commandes et boutons habituels.

 

Onglets fichiers

LDForge peut éditer plusieurs fichiers en même temps. Au-dessus de la fenêtre graphique se trouve les onglets correspondants à chaque fichier. Il suffit de cliquer sur un onglet pour rendre actif le fichier correspondant.

En cliquant sur la croix rouge, à droite de l'onglet actif, on peut fermer le fichier correspondant.

 

Modes

Mode 2D/3D

Dans le coin en haut à droite il est possible de choisir un mode d'affichage 2D ou 3D (de haut en bas et de gauche à droite):

En vue 2D il est possible de passer entre le mode sélection (Select Mode) et le mode dessin (Draw Mode). On peut déplacer la vue avec le bouton central de la souris, et zoomer avec sa molette.

En vue 3D le mode dessin (Draw Mode) est inactif, le mode sélection (Select Mode) est actif. On peut tourner autour des axes X-vue et Y-vue avec le bouton gauche de la souris, déplacer la vue avec le bouton central de la souris, et zoomer avec sa molette.

Avec "View / Reset View" on réinitialise la fenêtre graphique.

Mode sélection

Sélectionner une entité en cliquant dessus avec le bouton gauche de la souris, dans la fenêtre graphique ou dans la liste déroulante à droite.

Sélectionner une entité supplémentaire, en utilisant conjointement la touche Ctrl.

Pour sélectionner une plage d'entités sélectionner la première dans la liste, et utiliser conjointement la touche Maj en cliquant sur la dernière.

Utiliser la commande du menu Edit (ou les boutons de la barre d'outils correspondants) :

Nota : Une sélection peut être sauvegardé au format LDraw avec la commande "File / Export To...", et réutilisée dans un autre fichier par la commande "File / Insert From...".

Mode baguette magique

Mode de sélection où la sélection d'une entité, dans la fenêtre graphique, s'étend à toutes les entités liées successivement par un point (ligne) ou un bord (triangle ou quadrilatère).

Mode dessin

Dans la vue de la pièce, en mode 2D, il est possible de dessiner des lignes, triangles et quadrilatères.

Pour créer une ligne, cliquer le premier point à l'écran, puis cliquer deux fois au même endroit pour le second point. Faire la même chose au troisième ou quatrième point pour un triangle ou un quadrilatère. Un appui sur le bouton droit de la souris annule le point précédent. L'ordre antihoraire des points oriente la face des triangles et quadrilatères vers l'extérieur (en vert).

Attention il est possible de créer des quadrilatères dégénérés (bords croisés ou 3 points alignés).

Par défaut, les objets sont créés dans le plan X, Y ou Z = 0, suivant la vue sélectionnée.

Avec la commande "Edit / Set Draw Depth", il est possible de changer de niveau le plan.

Nota : La valeur est affectée suivant l'axe de la vue active (ici vue de dessous (Bottom)).

Mode rectangle

En mode rectangle, il est possible d'insérer directement des quadrilatères rectangulaires. Cliquer le premier coin puis double-cliquer pour le second point opposé en diagonale.

Appuyer sur le bouton droit de la souris pour annuler le dernier point cliqué.

Nota : La position du second point par rapport au premier va déterminer le sens BFC du rectangle. En direction Nord-Est ou Sud-Ouest il est vu côté extérieur et en direction Nord-Ouest ou Sud-Est il est vu côté intérieur.

Mode cercle

En mode cercle, il est possible d'insérer directement des primitives de cercle (edge), de disque (disc) et d'anneau (ring).

Pour un cercle, cliquer la position du centre puis double-cliquer pour le bord.

Pour un disque, cliquer la position du centre puis cliquer pour le bord et ensuite double-cliquer à nouveau sur la position du centre.

Pour un anneau, cliquer la position du centre puis cliquer pour le premier bord et ensuite double-cliquer pour le second bord. Le programme calcule automatiquement la combinaison de primitives "ring" nécessaires pour réaliser l'anneau demandé. Si certaines primitives n'existent pas, elles sont créées. Si aucune combinaison ne fonctionne alors des quadrilatères sont créés.

Appuyer sur le bouton droit de la souris pour annuler le dernier point cliqué.

Dans la partie listing cliquer sur le bouton "Tool Options" pour paramétrer la création.

La position du curseur pour le deuxième point définit le rayon et également l'orientation.

Mode chemin de lignes

En mode chemin de lignes (Line Path Mode) on peut créer une succession de lignes chaînées.

Appuyer sur le bouton droit de la souris pour annuler le point précédent du chemin en cours. Double cliquer sur le dernier point pour valider.

Image de fond

On peut insérer une image de fond avec la commande : "View / Set Overlay Image" :

Nota : Si le format de l'image n'est pas reconnu on obtient un message d'erreur (image .JPG par exemple) :

Puis on peut dessiner sur l'image.

La commande : "View / Clear Overlay Image" permet de supprimer l'image de fond.

 

Ajout d'entités d'un projet pièce

Le système LDraw ne connaît que 5 types d'entités représentés dans le fichier par le premier caractère de chaque ligne commençant par :

Elément LDraw prédéfini (Type 0 à 5)

Avec le menu "File / Insert From...", on insère un fichier au format LDraw sélectionné sur le disque dur.

Avec le menu "Insert / LDraw Code...", on insère une ou des lignes au format LDraw à partir du presse-papier. On peut également les insérer directement dans le listing en faisant un coller du presse-papier à l'endroit du curseur.

L'insertion se fait après la dernière ligne sélectionnée dans le listing.

Commentaire (Type 0)

Commande accessible par le menu "Insert / New Comment", ou le bouton de la barre d'outils correspondant.

Sous-fichier (Type 1)

Il s'agit ici en réalité d'un lien vers un fichier externe, soit un sous-fichier pour une pièce symétrique par exemple, ou une primitive pour les parties réutilisées par plusieurs pièces.

Commande accessible par le menu "Insert / New Subfile Reference", ou le bouton de la barre d'outils correspondant.

Insère l'instance d'un sous-fichier, à la position donnée, avec une taille et déformation définie par la matrice de transformation (Matrix).

Entrer les valeurs X, Y, Z du point d'insertion dans la boite de dialogue, ou utiliser les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du sous-fichier. Sélectionner la primitive dans l'une des catégories de la fenêtre centrale, ou le nom d'une pièce ou d'un sous-fichier de pièce dans le champ "File". Changer si besoin la taille et la déformation dans le champ "Matrix".

Dans la partie listing de la fenêtre graphique cliquer sur le bouton "Primitives" pour faire apparaître la liste des primitives existantes. Pour insérer une primitive dans la pièce en cours, la sélectionner puis faire un "glisser/déposer" dans la fenêtre graphique. La primitive est insérée à l'origine de la pièce. Double-cliquez dessus pour en modifier les paramètres.

Catégories des primitives standard, ou de haute résolution pour les branches finissant par (48) :

La commande du menu : "Tools / Inline" permet de décomposer un sous-fichier avec ses composants positionnés et configurés dans leur état en cours.

La commande du menu : "Tools / Deep Inline" fait la même chose de façon récursive jusqu'à obtenir des entités de base (ligne, triangle, quadrilatère, ligne conditionnelle).

S'il manque une primitive circulaire dans la bibliothèque, elle peut être générée par la commande "Tools / Make a Primitive". Voir chapitre "Projet de primitive circulaire".

Ligne (Type 2)

Commande accessible par le menu "Insert / New Line", ou le bouton de la barre d'outils correspondant.

Entrer les valeurs X, Y, Z des points définissant la ligne dans la boite de dialogue, ou utiliser les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut de la ligne.

Voir le chapitre Mode dessin, pour insérer une ligne ou le chapitre Mode chemin de lignes pour insérer des lignes chaînées, en mode 2D.

La commande "Tools / Make Borders" crée des lignes sur les bords de triangles ou quadrilatères. Attention, avec des triangles ou quadrilatères jointifs, il y a 2 lignes superposées à la jonction.

La commande "Tools / Demote Conditional Lines" convertit des lignes conditionnelles en lignes simples.

La commande "Tools / Split Lines..." découpe chaque ligne sélectionnée en N lignes identiques.

Triangle (Type 3)

Commande accessible par le menu "Insert / New Triangle", ou le bouton de la barre d'outils correspondant.

Entrer les valeurs X, Y, Z des points définissant la facette triangulaire dans la boite de dialogue, ou utiliser les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du triangle.

Voir le chapitre Mode dessin, pour insérer un triangle en mode 2D.

Les quadrilatères peuvent être décomposés en 2 triangles par le commande : "Tools / Split Quads".

Quadrilatère (Type 4)

Commande accessible par le menu "Insert / New Quadrilateral", ou le bouton de la barre d'outils correspondant.

Entrer les valeurs X, Y, Z des points définissant la facette quadrangulaire dans la boite de dialogue, ou utiliser les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du quadrilatère.

Voir le chapitre Mode dessin, pour insérer un quadrilatère en mode 2D.

Voir le chapitre Mode rectangle, pour insérer un quadrilatère carré ou rectangulaire, en mode 2D.

Les triangles d'un même plan, à bord commun et de même couleur peuvent être convertis en quadrilatères avec le programme externe Rectifier.

En Mode cercle, si aucune combinaison de primitives "ring" n'est possible pour créer un anneau, celui-ci est composé de quadrilatères.

Ligne conditionnelle (Type 5)

Commande accessible par le menu "Insert / New Conditional Line", ou le bouton de la barre d'outils correspondant.

Une ligne conditionnelle est définie par ses deux premiers points et ses angles de départ et de fin de vision sont donnés par les deux plans définis par cette ligne et les deux points supplémentaires.

Entrer les valeurs X, Y, Z des 2 premiers points définissant la ligne et les 2 derniers définissant les plans. Le bouton des couleurs permet de changer la Couleur des entités par défaut de la ligne.

Pour générer automatiquement des lignes conditionnelles, utilisez le programme externe "Edger 2".

Sommet ou point (Type 0 !LDFORGE)

Commande accessible par le menu "Insert / New Vertex", ou le bouton de la barre d'outils correspondant.

Entrer les valeurs X, Y, Z du point dans la boite de dialogue, ou utiliser les flèches incrémentales. Le bouton des couleurs permet de changer la Couleur des entités par défaut du point.

La commande "Tools / Make Corner Vertices" crée des points sur les sommets de lignes, triangles ou quadrilatères.

Ce type d'entité n'existant pas par défaut dans le format LDraw, il est sauvegardé dans le fichier LDraw sous forme de commentaire spécialisé :
0 !LDFORGE VERTEX 16 20 10 0 pour un sommet en couleur principale (16) positionné à X=20, Y=10, Z=0.

 

Couleur des entités

Toutes les entités graphiques peuvent être affectées d'une couleur. Les couleurs les plus courantes peuvent être sélectionnées à partir des boutons de la barre d'outils, sinon toutes les couleurs disponibles peuvent être sélectionnées par le menu : "Tools / Set Color" ou par le bouton de sélection de couleur dans les boites de dialogue de création d'entités.

La couleur peut être affectée directement au moment de la création d'une entité, ou ultérieurement en faisant une sélection.

Cliquer sur un des boutons colorés pour sélectionner une couleur LDraw officielle. Son nom s'affiche en bas à gauche. Le nom s'affiche également en survolant les boutons avec la souris.

Le numéro LDraw des couleurs, leur nom, et leur coloration est défini par le fichier LDConfig.ldr, se trouvant dans le dossier d'installation de la bibliothèque de pièces LDraw.

Cliquer sur le bouton "Direct Color" pour avoir les paramètres de la couleur sélectionnée.

Avec ce même bouton "Direct Color..." on peut définir une couleur personnalisée et l'utiliser. Son nom s'affiche alors de façon hexadécimale "0x2rrggbb". Attention, ce type de couleur ne doit pas être normalement utilisé pour des pièces officielles LDraw.org.

Il existe 2 couleurs spéciales dans les fichiers de définition des pièces. La couleur 16 pour les faces (triangles et quadrilatères) et sous-fichiers, et la couleur 24 pour les lignes et lignes conditionnelles. Cela permet de définir des couleurs différentes pour le même fichier de pièce dans un fichier modèle.

Normalement un fichier de pièce ne possède pas de couleur affectée (hors 16 et 24), sauf lorsqu'il y a un motif. L'affectation des couleurs peut aider temporairement pour créer les différentes parties d'une pièce, et en particulier pour définir des groupes de données utilisées par les programmes externes.

Les couleurs des faces s'affichent dans la fenêtre graphique si "Red/green BFC view" n'est pas coché dans la boite de dialogue "File / Settings", onglet "Interface". Voir chapitre paramétrage. On peut aussi les afficher/cacher avec la commande "View / BFC Red/Green View", ou le bouton correspondant de la barre d'outils.

On peut affecter automatiquement une couleur à une sélection. La commande "Tools / Auto-color", affecte la première couleur non utilisée.

La commande "Tools / Uncolor", supprime toutes les couleurs à la sélection (met en couleurs 16 et 24).

 

Sens des faces (BFC)

Le sens des faces permet de définir le côté intérieur et extérieur des faces, pour une meilleure utilisation des programmes de rendu.

Affichage couleurs affectées,
gris par défaut
Affichage sens des faces,
certaines mal orientées
Affichage sens des faces,
faces internes en rouge

Déclaration

Les déclarations sur le sens des faces dans le fichier sont accessibles par le menu : "Insert / New BFC Statement".

Visualisation

On peut afficher/cacher le sens des faces, dans la fenêtre graphique, avec la commande "View / BFC Red/Green View", ou le bouton correspondant de la barre d'outils. On peut également les afficher si "Red/green BFC view" est coché dans la boite de dialogue "File / Settings", onglet "Interface".

Inversion

On peut changer le sens des faces d'une sélection de triangles et de quadrilatères par le menu : "Tools / Invert".

Pour les primitives creuses (box, cyli,...) il faut ajouter une commande avant chaque primitive par le menu : "Insert / New BFC Statement", en cochant "INVERTNEXT".

Pour les primitives planes (rect, disc, ring,...) il faut changer de signe un des paramètres non nul de la matrice de transformation, sur l'axe perpendiculaire au plan de la primitive, par le menu : "Tools / Edit LDraw Code" ou en double-cliquant sur l'entité dans la fenêtre graphique ou le listing, en modifiant le signe d'un des paramètres du champ "Matrix".

 

Modification

Les éléments existants dans le fichier peuvent être modifiés en position et rotation, ou même transformés en taille, symétrie ou déformation.

 

Grilles

Les 3 grilles permettent de positionner, déplacer et tourner les objets graphiques suivant un pas plus ou moins fin.

Les valeurs sont définies par le menu : "File / Settings", onglet "Grids".

Le choix de la grille se fait dans le menu : "Move / Grids / Coarse Grid" pour la grille large, "Move / Grids / Medium Grid" pour la grille moyenne, "Move / Grids / Fine Grid" pour la grille fine, ou en utilisant les boutons correspondants.

Déplacement

Les éléments sélectionnées peuvent être déplacés en X, Y ou Z par les commandes : "Move / Move ...".

Le pas de déplacement dépend de la grille active et de son paramétrage.

En éditant une entité par le menu "Edit / Edit Selected Object" ou le menu contextuel, on peut changer ses coordonnées d'insertion, les coordonnées de ses points de définition ou les paramètres d'une primitive.

En éditant une entité par le menu "Edit / Edit Selected Object" ou le menu contextuel, on peut changer ses coordonnées d'insertion, les coordonnées de ses points de définition ou les paramètres d'une primitive.

Avec la commande du menu : "Tools / Replace Coordinates", on peut déplacer les entités type 1 ou un sommet d'entité type 2, 3, 4 ou 5.

Rotation

Les éléments sélectionnées peuvent être tournés autour des axes X, Y ou Z par les commandes : "Move / Rotate ...".

Le pas de rotation dépend de la grille active et de son paramétrage.

Par défaut le point de rotation est l'origine du fichier en cours (World origin), mais on peut aussi définir l'origine de l'objet sélectionné (Object origin) ou un point quelconque (Custom) qui peut être l'origine du fichier avec les valeurs par défaut X=0, Y=0 et Z=0. Il peut être sélectionné avec la commande : "Move / Set Rotation Point".

A chaque point de rotation "Custom" déclaré une ligne "0 ROTATION CENTER" est ajouté dans l'entête du fichier.

En éditant une primitive par menu "Edit / Edit Selected Object" ou le menu contextuel, on peut changer ses paramètres de rotation dans le champ "Matrix".

Symétrie

Pour symétriser une sélection aller dans le menu : "Tools / Flip".

La symétrie se fait par rapport au plan 0 perpendiculaire à l'axe coché dans la boite de dialogue.

Plusieurs axes de symétrie peuvent être cochés en même temps.

Coupe d'entités

On peut couper une ligne en segments équidistants avec le menu : "Tools / Split Lines...".

Entrer dans le champ "Amount of segments" le nombre de segments de lignes résultant de chaque ligne sélectionnée.

On peut couper un quadrilatère en deux triangles avec le menu : "Tools / Split Quad...".

Nota : On peut faire l'opération inverse avec "External Tools / Rectifier".

Modification du code LDraw

Avec la commande du menu : "Tools / Edit LDraw Code" on visualise le code LDraw d'une entité sélectionnée seule. Il est alors possible de la modifier directement.

En jouant sur le code, on peut modifier sa couleur, les valeurs de position des points définissant lignes, triangle et quadrilatère. Pour un sous-fichier ou une primitive on peut changer la position d'insertion ou le transformer complètement. Voir ma page : Déformation de primitives.

Modification des coordonnées

Après sélection d'une entité, avec la commande du menu contextuel : "Edit Selected Object" une boite de dialogue identique à celles décrites au chapitre Ajout d'entités d'un projet pièce s'ouvre. On peut changer les coordonnées des entités graphiques.

Arrondi des données

Avec la commande du menu : "Tools / Round Coordinates" on peut arrondir les données de la sélection à 3 chiffres après la virgule pour les positions et 4 chiffres pour la matrice de transformation par défaut.

C'est particulièrement utile après des rotations successives ou la création d'entités par les programmes externes.

On peut changer le nombre de décimales dans le paramétrage avec "File / Settings" dans l'onglet "Editing tools".

Suppression

La sélection courante peut être supprimée par le menu : "Edit / Delete", le menu contextuel "Delete", ou la touche "Suppr (Del)".

Historique des commandes

On peut supprimer la dernière commande avec du menu : "Edit / Undo", ou la rejouer avec "Edit / Redo".

 

Programmes externes

Les programmes externes permettent de générer des entités automatiquement. Ils fonctionnent soi sur les éléments sélectionnés lorsqu'ils utilisent une seule liste d'éléments, soi sur une discrimination par couleur lorsque plus d'une liste est nécessaire.

Les données générées sont insérées après la position du curseur dans le listing.

Ces programmes générant des entités avec beaucoup de chiffres après la virgule, il sera sans doute nécessaire d'arrondir les données avec la fonction "Tools / Round Coordinates".

Programme d'extrusion de faces sur une succession de lignes : Ytruder

Voir le manuel du programme : Ytruder, pour plus d'informations sur son utilisation spécifique.

Programme d'optimisation : Rectifier

Voir le manuel du programme : Rectifier, pour plus d'informations sur son utilisation spécifique.

Programme de coupe d'entités : Intersector

Voir le manuel du programme : Intersector, pour plus d'informations sur son utilisation spécifique.

Programme de lignes d'intersections : Isecalc

Génère des lignes à l'intersection de 2 groupes d'entités.

Voir le manuel du programme : Isecalc, pour plus d'informations sur son utilisation spécifique.

Programme d'extrusion de faces réglées : Coverer

Voir le manuel du programme : Coverer, pour plus d'informations sur son utilisation spécifique.

Programme de génération de lignes sur un maillage : Edger2

Nota : Les lignes créées sur les bords extérieurs d'une sélection sont mis en rouge, ce qui permet de les distinguer facilement.

Voir le manuel du programme : Edger2, pour plus d'informations sur son utilisation spécifique.

 

Menus

File (Fichier)

View (Visualisation)

Insert (Insertion)

Edit (Edition)

Move (Déplacement)

Tools (Outils)

External Tools (Outils Externes)

Help (Aide)

 

Menus contextuels

Les commandes principales sont aussi accessibles par le menu contextuel qui s'affiche avec le bouton droit de la souris dans la fenêtre graphique ou listing. Ce menu varie suivant le mode 2D/3D, s'il y a une sélection ou non, et le type d'entité sélectionné.

Hors sélection, en 2D Après sélection, en 3D

 

Barres d'outils

On peut afficher ou cacher les barres d'outils en cliquant avec le bouton droit de la souris dans la zone d'affichage des barres d'outils, puis en cochant ou décochant une des barres.

On peut déplacer les barres d'outils sur les quatre bords de la fenêtre, ou les rendre indépendantes. Pour cela, cliquer sur leur barre de pointillés, à leur gauche ou en haut, puis avec la souris faire glisser la barre à son nouvel emplacement.

Barre d'outils "File" (Fichier)

Barre d'outils "New Object" (Nouvel objet)

Barre d'outils "Basic tools" (Outils de base)

Barre d'outils "Select" (Sélection)

Barre d'outils "Grid" (Grille)

Barre d'outils "Display options" (Visualisation)

Barre d'outils "Editing tools" (Outils d'édition)

Barre d'outils "Editing modes" (Modes d'édition)

Barre d'outils "Colors" (Couleurs)

Barre d'outils "External programs" (Programmes externes)

 

Paramétrage

La boite de dialogue du paramétrage de LDForge s'ouvre à partir du menu "File / Settings".
Cliquer sur "OK" pour valider les modifications et sur "Cancel" pour les annuler.

Interface

L'onglet Interface, fixe les paramètres de l'interface :

Outils d'édition

L'onglet Editing tools, fixe les paramètres d'arrondi :

Profil utilisateur

L'onglet Profile, fixe les paramètres du profil utilisateur :

Raccourcis clavier

L'onglet Shortcuts, change les raccourcis clavier :

Barre d'outils des couleurs

L'onglet Color Toolbar, change les boutons de la barre d'outils couleurs :

Grilles

L'onglet Grids, change les pas de déplacement et de rotation :

Programmes externes

L'onglet External Programs, fixe le dossier d'installation des programmes externes :

Téléchargement

L'onglet Download, fixe les paramètres de téléchargement d'éléments de la bibliothèque LDraw :

 

Raccourcis clavier

Table des raccourcis clavier :

Fichier :Touches
Nouveau projetCtrl+N
Ouvrir un projet existantCtrl+O
SauverCtrl+S
Sauver sousCtrl+Maj+S
FermerCtrl+W
Fermer toutCtrl+Maj+W
Sortie du programmeCtrl+Q
 
Visualisation :Touches
Couleur/Sens BFC des facesMaj+B
Couleurs pseudo-aléatoiresMaj+R
 
Edition :Touches
AnnulerCtrl+Z
Rétablir la dernière action annuléeCtrl+Maj+Z
CouperCtrl+X
CopierCtrl+C
CollerCtrl+V
SupprimerSuppr (Del)
Sélectionner toutCtrl+A
Mode sélectionS
Mode baguette magiqueW
Mode dessinD
Mode rectangleR
Mode cercleC
Mode cheminP
Va à la ligne n°...Ctrl+G
 
Déplacement :Touches
Déplacement liste sélectionnée vers le hautTouche flèche page haut
Déplacement liste sélectionnée vers le basTouche flèche page bas
Déplacement -XTouche flèche gauche
Déplacement +XTouche flèche droit
Déplacement -YTouche flèche page haut
Déplacement +YTouche flèche page bas
Déplacement -ZTouche flèche bas
Déplacement +ZTouche flèche haut
Rotation -XCtrl+Touche flèche gauche
Rotation +XCtrl+Touche flèche droit
Rotation -YCtrl+Touche flèche page haut
Rotation +YCtrl+Touche flèche page bas
Rotation -ZCtrl+Touche flèche bas
Rotation +ZCtrl+Touche flèche haut
 
Outils :Touches
Fixer la couleurMaj+C
Couleur automatiqueCtrl+Maj+C
Inverser sens des facesCtrl+Maj+W
Décomposer premier niveauCtrl+I
Décomposer tous niveauxCtrl+Maj+I
InverserCtrl+Maj+F
 
Aide :Touches
Aide du programmeF1 (inactif)
 

 

Fichiers système

LDForge sauvegarde sa configuration dans le fichier :
C:/Users/[user]/LDForge/ldforge.cfg (remplacer [user] par votre nom d'utilisateur Windows).

LDForge sauvegarde la liste des primitives LDraw dans le fichier :
C:/Users/[user]/LDForge/prims.cfg (remplacer [user] par votre nom d'utilisateur Windows).

LDForge sauvegarde également des fichiers Dump en cas de crash dans le dossier :
C:/Users/[user]/AppData/Local/CrashDumps (remplacer [user] par votre nom d'utilisateur Windows).

 

Améliorations souhaitables

En premier je précise que la version testée (v0.1.999 Alpha B, v0.2 Alpha, v0.3) est en version de développement. Elle est malgré cela opérationnelle, mais attention n'est pas encore tout à fait stable (plantage possible avec perte de données).

Voici une liste d'améliorations souhaitables ou à envisager qui amélioreraient les possibilités du programme et sa facilité d'utilisation.

 

Tutoriels

 

Tutoriel intersection de primitives

Voici un exemple simple d'utilisation de LDForge.

But à atteindre :

Créer les lignes d'intersection de la boite et du cylindre.

1- Mettre ces 2 éléments dans un fichier temporaire et l'ouvrir avec LDForge.
2- Sélectionner les 2 entités.
3- Les décomposer en éléments de base avec la commande : "Tools / Deep Inline".

Coloration :

1- Sélectionner les 3 quadrilatères de la boite et les colorer en jaune (par exemple).
2- Sélectionner les 4 quadrilatères (2+2) du cylindre coupant les faces jaunes et les colorer en vert (par exemple).

Utiliser le programme externe Isecalc :

1- Lancer la commande : "External Program / Isecalc".
2- Sélectionner les 2 couleurs utilisées (ordre indifférent).
3- Valider en cliquant sur le bouton "OK".

Lignes d'intersection :

1- La commande précédente à créé 8 lignes, placées en fin de listing.
2- Sauvegarder le fichier temporaire.
3- Copier les 8 lignes créées dans le fichier temporaire pour les coller dans le fichier final.

Nota : L'usage du fichier temporaire est ici pratique pour garder dans le fichier final les 2 primitives non décomposées, en y ajoutant les 8 lignes d'intersection créées dans le fichier temporaire.

Nota : Si l'usage du fichier temporaire n'est pas nécessaire, on peut enlever globalement les couleurs devenues inutiles avec la commande : "Tools / Uncolor".

 

Tutoriel création de primitive rect.dat

Voici comment dessiner un parallélogramme et le transformer en primitive LDraw rect.dat.

Dessiner un carré, rectangle ou parallélogramme en mode 2d :

La seule condition à respecter est d'avoir les côtés opposés du quadrilatère parallèles.

1- Passer en mode 2D vue de dessus (par exemple).
2- Passer en mode dessin.
3- Créer le quadrilatère en cliquant 4 fois + 1 validation dans la fenêtre graphique.

Génération des bords :

1- Sélectionner le quadrilatère.
2- Lancer la commande : "Tools / Make Borders".

Génération de la primitive :

1- Sélectionner toutes les entités.
2- Lancer la commande : "External Programs / Rectifier".

 

Droits et Copyright

Le programme LDForge appartient à son auteur : Santeri Piippo.
Les autres programmes cités appartiennent à leurs ayants droits respectifs.

Cette page en Français est de J.C. Tchang.

Traduction et Adaptation : J.C. Tchang.