Tutoriel :
Editer des pièces LDraw avec Meshmixer

Mise à jour de la page : 23 septembre 2014.
    Set 700/1 de 1950
J.C. Tchang
LDraw and Meshmixer tutorials
On LDraw.org Forum
.

Il s'agit ici d'un tutoriel permettant de modifier un maillage LDraw avec Meshmixer de Autodesk, dans le but principal de créer des pièces à motifs. Les programmes LDView, stl2dat et Edger2 sont utilisés lors des phases de conversion avec le format LDraw.

Ce tutoriel a été créé par Philo sous forme Vidéo. Il a été ici traduit et converti en page HTML par J.C. Tchang.


Exemple de fichier LDraw sous Meshmixer version 2.5 w64 du 11-08-2014 (v10.5.79).

 

Téléchargement

 

Conversion et visualisation

Conversion LDraw -> STL :
  • Le maillage au format LDraw (ici le pied d'une "Figure Friends") est visualisé avec LDView.
  • Le mode BFC est activé pour visualiser le sens des faces et vérifier que toutes les faces externes soient vertes, pour prévenir l'inversion de triangles au moment de l'exportation.
  • L'exportation au format STL se fait par le menu "File / Export" et en sélectionnant comme "Type" dans la fenêtre qui s'ouvre : "STL: Stereo Lithography File" et dans les Options de ce type "LDraw Units" comme échelle (Scale).
Importation dans Meshmixer :
  • Après avoir ouvert Meshmixer, importer le fichier sauvegardé avec le menu "File / Import" et en sélectionnant le fichier .stl sur le disque.
  • On peut aussi importer directement le fichier sous Windows en le sélectionnant avec l'explorateur et avec un clic droit l'ouvrir avec "Ouvrir avec... / Meshmixer". Nota : l'association STL - Meshmixer doit avoir été fait au moment de l'installation du programme ou ultérieurement.
  • En raison du sens particulier des Y dans le format LDraw (Y+ vers le bas) l'affichage de la pièce est inversée sous Meshmixer.
Affichage dans Meshmixer :
  • Utiliser ALT+clic droit de la souris pour faire tourner la pièce.
  • Si le mouvement est bloqué, alors appuyer sur la touche "Espace" et sélectionner le bouton "Camera / Free".
  • L'affichage avec rendu lissé uni est bien mais n'est pas facile à utiliser dans notre cas.
  • Cliquer sur le bouton "Shaders" du menu à gauche et glisser la seconde sphère sur la pièce à l'écran. Dans cette configuration l'extérieur de la pièce est gris et l'intérieur rose.
  • Puis appuyer sur la touche "Espace" et cliquer sur le second bouton de "Mesh / Normals", pour annuler le lissage. Dans cette configuration les facettes réelles de la pièce apparaissent.
  • On peut également afficher les bords de chaque facette avec le menu "View / Toggle Wireframe" ou en appuyant sur la touche "W" (voir image suivante).
Sauvegarde :
  • Pour sauvegarder son travail au format natif Meshmixer (.mix), il suffit d'aller dans le menu "File / Save As".

Exportation et conversion au format LDraw :

  • Pour convertir son travail au format LDraw (.dat), il faut aller dans le menu "File / Export", et choisir comme "Type" : "STL ASCII Format" pour d'abord créer un fichier .stl.
  • Puis convertir ce fichier .stl en fichier .dat avec l'utilitaire stl2dat.
  • stl2dat peut être utilisé seul sous "Invite de Commande" ou sous Windows avec l'interface graphique LETGUI en choisissant l'option de conversion "-raw" (conversion sans traitement additionnel).
  • On peut changer les valeurs de la matrice de transformation si l'échelle de la pièce n'était pas en LDU (LDraw Unit).
  • Visualiser le résultat avec LDView.

Lignes de bords et lignes conditionnelles :

  • Les lignes de bords et les lignes conditionnelles sont perdues au cours des opérations.
  • Elles peuvent être générées par stl2dat si l'option -raw n'est pas utilisé, mais le résultat n'est pas probant.
  • Elles peuvent être générées de façon plus convaincante par Edger2. Avec l'option "-u-" seules les lignes conditionnelles sont créés. Les lignes de bords extérieurs pouvant venir avec les autres parties de la pièce.

 

Création d'un motif simple avec Meshmixer

Ouverture du projet précédent :
  • Ouvrir le projet avec le menu "File / Open" et en sélectionnant le fichier .mix sur le disque, ou en cliquant sur le bouton "Open" à l'ouverture de Meshmixer.
Sélection de faces :
  • On peut créer un motif simple en colorant des triangles.
  • Cliquer sur le bouton du menu "Select" ou taper "S".
  • Puis tracer un trait en partant de l'extérieur de la pièce avec le bouton gauche de la souris. Tous les triangles traversés par le trait vont changer de couleur, même ceux en arrière plan.
  • Lorsqu'on relâche la souris les triangles se colorent en orange (voir image suivante).
Complément de sélection :
  • On peut aussi sélectionner les triangles visibles en cliquant avec le bouton gauche de la souris et en passant sur les triangles.
  • Compléter la sélection en utilisant la souris comme un pinceau.
  • L'épaisseur de l'outil de sélection peut être ajustée avec le curseur "Size".
  • Avec la touche "Maj", l'outil désélectionne.
  • La touche "Echap" annule la sélection.
Sauvegarde de la sélection dans un groupe :
  • Sauvegarder ensuite la sélection dans un groupe de faces avec "Select / Modify / Create FaceGroup" (Ctrl+G).
  • Si le groupe ne s'affiche pas en couleur (ici en bleu), appuyer sur la touche "Espace" et cliquer le second bouton de "Mesh / Color".
  • Il est bon également de sauvegarder sa session en vu des étapes suivantes.
Séparation des groupes :
  • Il n'y a pas de façon simple pour exporter un maillage coloré vers LDraw, donc il va falloir exporter chaque couleur séparément.
  • Sélectionner une des facettes à exporter, puis étendre à tout le groupe avec "Select / Modify / Expand to groups" (G).
  • Séparer le groupe avec "Select / Edit / Separate" (Y). Cela sépare le groupe dans un nouvel objet. Noter la ligne de bord bleue qui apparaît au milieu.
  • La fenêtre "Object Browser" permet de sélectionner l'objet de son choix, le rendre transparent et non sélectionnable ou le cacher. Si cette fenêtre n'apparait pas aller dans le menu "View / Show Objects Browser" (Ctrl+Maj+O).
Exportation de chaque objet :
  • Sélectionner un des objets à exporter.
  • L'exporter au format stl avec le menu "File / Export" et l'option "Type: STL ASCII Format".
  • Recommencer avec l'objet suivant.
  • Convertir ensuite chaque ficher stl avec stl2dat + LETGUI.
  • Puis assembler et colorer les différents morceaux avec MLCad ou LDDP pour visualiser en final le résultat avec LDView.

 

Amélioration du motif par déplacement des nœuds

Déplacer les noeuds :
  • Ouvrir le projet de base avant séparation avec Meshmixer.
  • Il est nécessaire de reprendre la forme de la chaussure, la forme n'est pas assez lisse et la semelle est trop épaisse.
  • Avec "Sculpt / Drag" on va déplacer les sommets du maillage. Par défaut Meshmixer réalise des maillages très fins, mais ce n'est pas ce que l'on veut faire. Si on a commencé, faire une annulation "Undo" (Ctrl+Z) et décocher "Enable Refinement".
  • La taille de la brosse doit être petite pour déplacer 1 seul sommet à la fois.
  • Il est maintenant facile de déplacer les sommets.
  • Le déplacement de sommets peut déformer la pièce, et nécessiter plusieurs ajustements.
Précaution :
  • Pour éviter de déplacer un sommet définissant la forme extérieure de la pièce, dérouler le menu "Filters" et cocher "Hold Boundary". A partir de ce moment les sommets internes à la forme peuvent être déplacés mais ceux de la forme externe sont figés.
  • Sauvegarder le travail.

 

Amélioration du motif par redéfinition du maillage

Augmentation locale du maillage :
  • Utiliser l'outil "Sculpt / Brushes / Refine".
  • Mais, par défaut cet outil, avec une valeur basse à "Strength" (0) et moyenne à "size" (50) l'augmentation est trop importante pour notre contexte en balayant la surface.
  • Vous pouvez avoir un meilleur résultat en cliquant sur les sommets, en s'assurant que "Flow" est décoché, mais ce n'est pas toujours facile à maitriser.
Augmentation du maillage d'une sélection :
  • On peut aussi redéfinir la maillage d'une sélection.
  • Sélectionner une zone à redéfinir.
  • Puis aller dans "Select / Edit / Remesh" (R) et déplacer le curseur "Remesh" pour avoir le résultat escompté.
  • Cliquer sur "Accept" (A) pour valider.
Simplification locale du maillage :
  • Utiliser l'outil "Sculpt / Brushes / Drag". Nota : "Refinement / Enable" doit être décoché.
  • Puis déplacer les sommets à supprimer vers un sommet à garder, mais vous ne pouvez pas avec cet outil les superposer.
  • Utiliser l'outil "Sculpt / Brushes / Pinch" pour compléter, le curseur "Depth" doit être à 0.
  • Puis cliquer sur "Sculpt / Brushes / Reduce" pour réduire le maillage.

 

Amélioration du motif par inversion de paire de triangles

Passer de 2 à 4 triangles :
  • Sélectionner les 2 triangles à inverser.
  • Puis avec "Select / Edit / Remesh" (R), déplacer le curseur "Remesh" pour avoir 4 triangles et cliquer sur "Accept".
Repositionner le sommet central :
  • Utiliser l'outil "Sculpt / Brushes / Drag" pour déplacer le sommet central de façon à aligner les 2 segments à garder.
Réduire le nombre de triangles :
  • Sélectionner les 4 triangles.
  • Puis cliquer sur "Edit / Reduce" pour réduire le maillage.

 

Modification de forme

Ce second tutoriel est basé sur un message de Stan Isachenko sur le forum LDraw.org le 04-11-2012 : Help with parts creation. Suite à cette demande, Philo a réalisé la modification de l'œil et a expliqué la méthode utilisée.

Réaliser une variante de la même pièce :
  • La pièce Lego 92743 représentant une tête de Gungan (personnage Star Wars), avec des yeux globuleux existait dans LDD et a pu être exporté au format LDraw sans le motif (En haut à droite avec motif sur la photo).
  • Mais une variante de forme existe sous le numéro 30371 avec des yeux fendus (A gauche et en bas à droite sur la photo).
  • Cette seconde version n'existant pas sous LDD, elle ne pouvait être exportée et une solution était demandée pour sa création sous LDraw.
Méthode utilisée par Philo :
  • Exportation au format .stl de la version de base.
  • Ouverture du fichier .stl avec Meshmixer (programme libre de sculpture de modèle 3D).
  • Sculpture de l'œil, en retreignant l'action des outils sur la face avant de l'œil en utilisant l'outil groupe apparu avec la version 8 de Meshmixer.
  • Diminution du nombre de triangles avec l'outil "Reduce".
  • Exportation du résultat au format LDraw avec stl2dat.
  • Réintroduction des lignes de bord à partir des fichiers originaux.
  • En dépit de l'utilisation des outils de Meshmixer sur une zone limitée, la zone autour de l'œil a bougé un peu et la ligne de bord autour de la pupille ne correspondait pas parfaitement. Fixé cela en faisant un sous-fichier des lignes de bord originales et utilisé l'utilitaire Unificator avec attraction sur un sous-fichier.
  • Création de la ligne de bord du milieu avec Edger2 et une édition manuelle du fichier final.
Résultat :
  • Résultat des 2 variantes sous LDView.

 

Droits et Copyright

Ces tutoriels ont été faits à l'origine par (c) Philo (Philippe Hurbain).

Vous pouvez le retrouver sur son site et sa page des utilitaires LDraw.

Les autres programmes ou marques cités appartiennent à leurs ayants droits respectifs.

Traduction et Adaptation de ce manuel : J.C. Tchang.